sadadw1 opened a new issue, #679: URL: https://github.com/apache/ozhera/issues/679
### What happened? In `ozhera-operator/ozhera-operator-service/.../HeraResourceEventHandler.java`, the private field that holds the `RocketMQService` bean is misspelled `rocketMQSerivce` (the word `Service` is misspelled `Serivce`): ```java @javax.annotation.Resource private RocketMQService rocketMQSerivce; ``` It is used later as `rocketMQSerivce.createTopic(nameserver);`. ### Impact Naming-only issue. `rocketMQSerivce` is a private field with no public accessor, so this does not affect any business logic or external API, but it harms readability. ### Suggested fix Rename the private field `rocketMQSerivce` → `rocketMQService` (declaration + the single usage). ```diff - private RocketMQService rocketMQSerivce; + private RocketMQService rocketMQService; ... - rocketMQSerivce.createTopic(nameserver); + rocketMQService.createTopic(nameserver); ``` -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: [email protected] For queries about this service, please contact Infrastructure at: [email protected] --------------------------------------------------------------------- To unsubscribe, e-mail: [email protected] For additional commands, e-mail: [email protected]
