Upgrade other dependencies

Project: http://git-wip-us.apache.org/repos/asf/polygene-java/repo
Commit: http://git-wip-us.apache.org/repos/asf/polygene-java/commit/ec2855f5
Tree: http://git-wip-us.apache.org/repos/asf/polygene-java/tree/ec2855f5
Diff: http://git-wip-us.apache.org/repos/asf/polygene-java/diff/ec2855f5

Branch: refs/heads/develop
Commit: ec2855f5593979966913c7fcc2e846e9a7c6c485
Parents: 361f6fe
Author: Paul Merlin <paulmer...@apache.org>
Authored: Mon Jul 17 08:56:39 2017 +0200
Committer: Paul Merlin <paulmer...@apache.org>
Committed: Mon Jul 17 08:56:39 2017 +0200

----------------------------------------------------------------------
 dependencies.gradle | 58 ++++++++++++++++++++++++------------------------
 1 file changed, 29 insertions(+), 29 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/polygene-java/blob/ec2855f5/dependencies.gradle
----------------------------------------------------------------------
diff --git a/dependencies.gradle b/dependencies.gradle
index ef62cf2..f9bc3de 100644
--- a/dependencies.gradle
+++ b/dependencies.gradle
@@ -31,7 +31,7 @@ dependencies.repositoriesUrls << [
 
 // Core dependencies
 def asmVersion = '5.2'
-def javaxJsonVersion = '1.0'
+def javaxJsonVersion = '1.1'
 def osgiVersion = '4.3.1'
 dependencies.libraries << [
   asm        : "org.ow2.asm:asm:$asmVersion",
@@ -44,41 +44,41 @@ dependencies.libraries << [
 // Extensions, Libraries and Tools dependencies
 def bonecpVersion = '0.8.0.RELEASE'
 def bouncyVersion = '1.57'
-def cassandraClientVersion = '3.2.0'
-def codahaleMetricsVersion = '3.2.2'
+def cassandraClientVersion = '3.3.0'
+def codahaleMetricsVersion = '3.2.3'
 def commonsDbcpVersion = '2.1.1'
-def commonsLangVersion = '3.5'
+def commonsLangVersion = '3.6'
 def commonsValidatorVersion = '1.6'
 def derbyVersion = '10.13.1.1'
 def ehcacheVersion = '3.3.1'
 def elasticsearchVersion = '5.5.0'
 def freemarkerVersion = '2.3.26-incubating'
-def geodeVersion = '1.1.1'
-def groovyVersion = '2.4.10'
-def hazelcastVersion = '3.8'
+def geodeVersion = '1.2.0'
+def groovyVersion = '2.4.12'
+def hazelcastVersion = '3.8.3'
 def httpClientVersion = '4.5.3'
-def jacksonVersion = '2.8.7'
+def jacksonVersion = '2.8.9'
 def jaxbApiVersion = '2.2.12'
-def jcloudsVersion = '2.0.1'
+def jcloudsVersion = '2.0.2'
 def jdbmVersion = '2.4'
 def jedisVersion = '2.9.0'
 def jettyVersion = '9.2.17.v20160517' // 9.3.x Tests fail!
-def johnzonVersion = '1.0.0'
-def jooqVersion = '3.9.1'
+def johnzonVersion = '1.1.1'
+def jooqVersion = '3.9.3'
 def leveldbVersion = '0.9'
 def leveldbJniVersion = '1.8'
 def liquibaseVersion = '3.5.3'
 def mongodbVersion = '3.4.2'
-def msgpackVersion = '0.8.12'
-def restletVersion = '2.3.9'
+def msgpackVersion = '0.8.13'
+def restletVersion = '2.3.10'
 def rdfVersion = '2.7.16' // 2.8.x change query results!! 4.x exists
 def riakVersion = '2.1.1'
 def servletVersion = '3.1.0'
-def shiroVersion = '1.3.2'
+def shiroVersion = '1.4.0'
 def slf4jVersion = '1.7.25'
 def solrVersion = "1.4.1" // 4.x Fails to compile!
-def springVersion = '4.3.7.RELEASE'
-def spymemcachedVersion = '2.12.2'
+def springVersion = '4.3.9.RELEASE'
+def spymemcachedVersion = '2.12.3'
 def velocityVersion = '1.7'
 dependencies.libraries << [
   bonecp              : "com.jolbox:bonecp:$bonecpVersion",
@@ -170,7 +170,7 @@ dependencies.libraries << [
 
 // Tools dependencies
 def jgoodiesLooksVersion = '2.7.0'
-def pdfboxVersion = '2.0.4'
+def pdfboxVersion = '2.0.6'
 def prefuseVersion = '1.0.1'
 dependencies.libraries << [
   jgoodies_looks: "com.jgoodies:jgoodies-looks:$jgoodiesLooksVersion",
@@ -179,20 +179,20 @@ dependencies.libraries << [
 ]
 
 // Runtime, Test and Samples dependencies
-def awaitilityVersion = '2.0.0'
+def awaitilityVersion = '3.0.0'
 def dnsJavaVersion = '2.1.8'
 def dockerJUnitVersion = '0.3'
 def easyMockVersion = '3.4'
-def embedMongoVersion = '1.50.5' // 2.0.0 exists
-def h2Version = '1.4.194'
+def embedMongoVersion = '2.0.0' // 2.0.0 exists
+def h2Version = '1.4.196'
 def hamcrestVersion = '1.3'
 def jaxRsApiVersion = '2.0.1'
 def junitVersion = '4.12'
-def logbackVersion = '1.2.2' // TODO Replace with Apache Log4j 2
-def mockitoVersion = '2.7.21'
+def logbackVersion = '1.2.3' // TODO Replace with Apache Log4j 2
+def mockitoVersion = '2.8.47'
 def mysqlVersion = '6.0.6'
-def postgresqlVersion = '42.0.0'
-def sqliteVersion = '3.16.1'
+def postgresqlVersion = '42.1.3'
+def sqliteVersion = '3.19.3'
 def xmlUnitVersion = '2.3.0'
 dependencies.libraries << [
   awaitility        : "org.awaitility:awaitility:$awaitilityVersion",
@@ -278,11 +278,11 @@ dependencies.buildToolsVersions << [
 // Docker Images
 dependencies.dockerImagesVersions << [
   cassandra: 'cassandra:3.10',
-  memcached: 'memcached:1.4.36-alpine',
+  memcached: 'memcached:1.4.39-alpine',
   mariadb  : 'mariadb:10.1.21',
-  mongo    : 'mongo:3.5.8',
-  postgres : 'postgres:9.6.2-alpine',
-  redis    : 'redis:3.2.8-alpine',
+  mongo    : 'mongo:3.5.10',
+  postgres : 'postgres:9.6.3-alpine',
+  redis    : 'redis:4.0.0-alpine',
   riak     : 'basho/riak-kv:ubuntu-2.2.3',
-  s3server : 'scality/s3server:mem-6a8e1cd'
+  s3server : 'scality/s3server:mem-bb2a38c0'
 ]

Reply via email to