[ 
https://issues.apache.org/jira/browse/ROL-2153?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

David Johnson updated ROL-2153:
-------------------------------
    Description: 
Upgrade to 2.5.21 before releasing Roller 6.

Upgrading may elimniate the error message below, which is seen when running 
Roller 6 via Docker Compose but does not prevent Roller from functioning 
properly:

{code}
roller_1      | 22:21:58.976 [main] ERROR 
org.apache.struts2.convention.DefaultClassFinder - Unable to read class 
[org.apache.roller.weblogger.ui.struts2.editor.EntryEdit]
roller_1      | java.lang.UnsupportedOperationException: This feature requires 
ASM7
roller_1      |         at 
org.objectweb.asm.ClassVisitor.visitNestMember(ClassVisitor.java:236) 
~[asm-7.0.jar:7.0]
roller_1      |         at 
org.objectweb.asm.ClassReader.accept(ClassReader.java:651) ~[asm-7.0.jar:7.0]
roller_1      |         at 
org.objectweb.asm.ClassReader.accept(ClassReader.java:391) ~[asm-7.0.jar:7.0]
roller_1      |         at 
org.apache.struts2.convention.DefaultClassFinder.readClassDef(DefaultClassFinder.java:462)
 ~[struts2-convention-plugin-2.5.20.jar:2.5.20]
roller_1      |         at 
org.apache.struts2.convention.DefaultClassFinder.<init>(DefaultClassFinder.java:93)
 [struts2-convention-plugin-2.5.20.jar:2.5.20]
roller_1      |         at 
org.apache.struts2.convention.PackageBasedActionConfigBuilder.buildClassFinder(PackageBasedActionConfigBuilder.java:395)
 [struts2-convention-plugin-2.5.20.jar:2.5.20]
roller_1      |         at 
org.apache.struts2.convention.PackageBasedActionConfigBuilder.findActions(PackageBasedActionConfigBuilder.java:377)
 [struts2-convention-plugin-2.5.20.jar:2.5.20]
roller_1      |         at 
org.apache.struts2.convention.PackageBasedActionConfigBuilder.buildActionConf
{code}

If upgrading does not fix this, then we should document the above issue as a 
"known issue"

  was:
Upgrade to 2.5.21 before releasing Roller 6.

Upgrading may elimniate the error message below, which is seen when running 
Roller 6 via Docker Compose but does not prevent Roller from functioning 
properly:

{{roller_1      | 22:21:58.976 [main] ERROR 
org.apache.struts2.convention.DefaultClassFinder - Unable to read class 
[org.apache.roller.weblogger.ui.struts2.editor.EntryEdit]
roller_1      | java.lang.UnsupportedOperationException: This feature requires 
ASM7
roller_1      |         at 
org.objectweb.asm.ClassVisitor.visitNestMember(ClassVisitor.java:236) 
~[asm-7.0.jar:7.0]
roller_1      |         at 
org.objectweb.asm.ClassReader.accept(ClassReader.java:651) ~[asm-7.0.jar:7.0]
roller_1      |         at 
org.objectweb.asm.ClassReader.accept(ClassReader.java:391) ~[asm-7.0.jar:7.0]
roller_1      |         at 
org.apache.struts2.convention.DefaultClassFinder.readClassDef(DefaultClassFinder.java:462)
 ~[struts2-convention-plugin-2.5.20.jar:2.5.20]
roller_1      |         at 
org.apache.struts2.convention.DefaultClassFinder.<init>(DefaultClassFinder.java:93)
 [struts2-convention-plugin-2.5.20.jar:2.5.20]
roller_1      |         at 
org.apache.struts2.convention.PackageBasedActionConfigBuilder.buildClassFinder(PackageBasedActionConfigBuilder.java:395)
 [struts2-convention-plugin-2.5.20.jar:2.5.20]
roller_1      |         at 
org.apache.struts2.convention.PackageBasedActionConfigBuilder.findActions(PackageBasedActionConfigBuilder.java:377)
 [struts2-convention-plugin-2.5.20.jar:2.5.20]
roller_1      |         at 
org.apache.struts2.convention.PackageBasedActionConfigBuilder.buildActionConf}}

If upgrading does not fix this, then we should document the above issue as a 
"known issue"


> Upgrade to Struts 2.5.21 when released
> --------------------------------------
>
>                 Key: ROL-2153
>                 URL: https://issues.apache.org/jira/browse/ROL-2153
>             Project: Apache Roller
>          Issue Type: Task
>          Components: User Interface - General
>    Affects Versions: 6.0.0
>            Reporter: David Johnson
>            Assignee: David Johnson
>            Priority: Major
>             Fix For: 6.0.0
>
>
> Upgrade to 2.5.21 before releasing Roller 6.
> Upgrading may elimniate the error message below, which is seen when running 
> Roller 6 via Docker Compose but does not prevent Roller from functioning 
> properly:
> {code}
> roller_1      | 22:21:58.976 [main] ERROR 
> org.apache.struts2.convention.DefaultClassFinder - Unable to read class 
> [org.apache.roller.weblogger.ui.struts2.editor.EntryEdit]
> roller_1      | java.lang.UnsupportedOperationException: This feature 
> requires ASM7
> roller_1      |       at 
> org.objectweb.asm.ClassVisitor.visitNestMember(ClassVisitor.java:236) 
> ~[asm-7.0.jar:7.0]
> roller_1      |       at 
> org.objectweb.asm.ClassReader.accept(ClassReader.java:651) ~[asm-7.0.jar:7.0]
> roller_1      |       at 
> org.objectweb.asm.ClassReader.accept(ClassReader.java:391) ~[asm-7.0.jar:7.0]
> roller_1      |       at 
> org.apache.struts2.convention.DefaultClassFinder.readClassDef(DefaultClassFinder.java:462)
>  ~[struts2-convention-plugin-2.5.20.jar:2.5.20]
> roller_1      |       at 
> org.apache.struts2.convention.DefaultClassFinder.<init>(DefaultClassFinder.java:93)
>  [struts2-convention-plugin-2.5.20.jar:2.5.20]
> roller_1      |       at 
> org.apache.struts2.convention.PackageBasedActionConfigBuilder.buildClassFinder(PackageBasedActionConfigBuilder.java:395)
>  [struts2-convention-plugin-2.5.20.jar:2.5.20]
> roller_1      |       at 
> org.apache.struts2.convention.PackageBasedActionConfigBuilder.findActions(PackageBasedActionConfigBuilder.java:377)
>  [struts2-convention-plugin-2.5.20.jar:2.5.20]
> roller_1      |       at 
> org.apache.struts2.convention.PackageBasedActionConfigBuilder.buildActionConf
> {code}
> If upgrading does not fix this, then we should document the above issue as a 
> "known issue"



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to