[ 
https://issues.apache.org/jira/browse/SAMZA-1037?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Nicolas Colomer updated SAMZA-1037:
-----------------------------------
    Summary: CDH4.5.0 support broken on Samza 0.11  (was: CDH4.5.0 support on 
Samza 0.11)

> CDH4.5.0 support broken on Samza 0.11
> -------------------------------------
>
>                 Key: SAMZA-1037
>                 URL: https://issues.apache.org/jira/browse/SAMZA-1037
>             Project: Samza
>          Issue Type: Bug
>    Affects Versions: 0.11
>            Reporter: Nicolas Colomer
>            Priority: Minor
>
> We did not achieved to make Samza 0.11 (as 0.10 and master) run with 
> CDH4.5.0, even following procedure described 
> [here|http://samza.apache.org/learn/tutorials/0.10/deploy-samza-to-CDH.html] 
> in the documentation.
> Build goes fine but everything crash due to some dependency collision at 
> runtime: we spotted at least org.codehaus.jackson and org.apache.zookeeper, 
> but there's probably more.
> We tried from surgical maven exclusions to dependency shading (recreating a 
> CDH4.5.0 artifact) with no success. We eventually would succeed with the 
> latter but some other dependencies (among which apache commons) collided with 
> our jobs specific ones.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to