[ 
https://issues.apache.org/jira/browse/SAMZA-1594?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16373410#comment-16373410
 ] 

ASF GitHub Bot commented on SAMZA-1594:
---------------------------------------

GitHub user shanthoosh opened a pull request:

    https://github.com/apache/samza/pull/427

    SAMZA-1594: Fix ScalaCompileOptions errors with higher gradle version.

    When samza repository is built with the gradle version greater than 3.0, we 
notice the following build failure.
    
    No such property: useAnt for class: 
org.gradle.api.tasks.scala.ScalaCompileOptions  
    
    This needs to be fixed to build samza with  gradle version >= 3.0.
    


You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/shanthoosh/samza fix_scalac_compile_options

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/samza/pull/427.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #427
    
----
commit 411f1c407607797e6b8e1fdce5aa6af1f9534469
Author: Shanthoosh Venkataraman <svenkataraman@...>
Date:   2018-02-22T20:37:44Z

    SAMZA-1594: Fix ScalaCompileOptions errors with higher gradle version.

----


> Fix ScalaCompileOptions errors originating from build.gradle.
> -------------------------------------------------------------
>
>                 Key: SAMZA-1594
>                 URL: https://issues.apache.org/jira/browse/SAMZA-1594
>             Project: Samza
>          Issue Type: Improvement
>            Reporter: Shanthoosh Venkataraman
>            Assignee: Shanthoosh Venkataraman
>            Priority: Major
>
> When samza repository is built with the gradle version greater than 3.0, we 
> notice the following build failure.
> {code:java}
> No such property: useAnt for class: 
> org.gradle.api.tasks.scala.ScalaCompileOptions  
> {code}
> This needs to be fixed to build samza with  gradle version >= 3.0.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to