Repository: samza
Updated Branches:
  refs/heads/master 526c1d25d -> 47881a24b


SAMZA-1594: Remove ScalaCompileOptions to make samza codebase build with gradle 
version > 3.0.

When samza repository is built with the gradle version greater than 3.0, we 
notice the following build failure.

No such property: useAnt for class: 
org.gradle.api.tasks.scala.ScalaCompileOptions

This needs to be fixed to build samza with  gradle version >= 3.0.

Author: Shanthoosh Venkataraman <svenkatara...@linkedin.com>

Reviewers: Xinyu Liu <xinyuliu...@gmail.com>

Closes #427 from shanthoosh/fix_scalac_compile_options


Project: http://git-wip-us.apache.org/repos/asf/samza/repo
Commit: http://git-wip-us.apache.org/repos/asf/samza/commit/47881a24
Tree: http://git-wip-us.apache.org/repos/asf/samza/tree/47881a24
Diff: http://git-wip-us.apache.org/repos/asf/samza/diff/47881a24

Branch: refs/heads/master
Commit: 47881a24b941031f7ac560c4c75c5778aa5bacf9
Parents: 526c1d2
Author: Shanthoosh Venkataraman <svenkatara...@linkedin.com>
Authored: Thu Feb 22 15:58:39 2018 -0800
Committer: xiliu <xi...@linkedin.com>
Committed: Thu Feb 22 15:58:39 2018 -0800

----------------------------------------------------------------------
 build.gradle | 2 --
 1 file changed, 2 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/samza/blob/47881a24/build.gradle
----------------------------------------------------------------------
diff --git a/build.gradle b/build.gradle
index d357645..4aab830 100644
--- a/build.gradle
+++ b/build.gradle
@@ -118,8 +118,6 @@ subprojects {
   tasks.withType(ScalaCompile) {
     // show compile errors in console output
     logging.setLevel LogLevel.WARN
-    scalaCompileOptions.fork = false
-    scalaCompileOptions.useAnt = true
   }
 
   tasks.withType(Test) {

Reply via email to