Repository: spark
Updated Branches:
  refs/heads/branch-2.0 54001cb12 -> b40663541


[SPARK-16061][SQL][MINOR] The property 
"spark.streaming.stateStore.maintenanceInterval" should be renamed to 
"spark.sql.streaming.stateStore.maintenanceInterval"

## What changes were proposed in this pull request?
The property spark.streaming.stateStore.maintenanceInterval should be renamed 
and harmonized with other properties related to Structured Streaming like 
spark.sql.streaming.stateStore.minDeltasForSnapshot.

## How was this patch tested?
Existing unit tests.

Author: Kousuke Saruta <saru...@oss.nttdata.co.jp>

Closes #13777 from sarutak/SPARK-16061.

(cherry picked from commit 6daa8cf1a642a669cd3a0305036c4390e4336a73)
Signed-off-by: Reynold Xin <r...@databricks.com>


Project: http://git-wip-us.apache.org/repos/asf/spark/repo
Commit: http://git-wip-us.apache.org/repos/asf/spark/commit/b4066354
Tree: http://git-wip-us.apache.org/repos/asf/spark/tree/b4066354
Diff: http://git-wip-us.apache.org/repos/asf/spark/diff/b4066354

Branch: refs/heads/branch-2.0
Commit: b4066354141b933cdfdfdf266c6d4ff21338dcdf
Parents: 54001cb
Author: Kousuke Saruta <saru...@oss.nttdata.co.jp>
Authored: Mon Jun 20 15:12:40 2016 -0700
Committer: Reynold Xin <r...@databricks.com>
Committed: Mon Jun 20 15:12:45 2016 -0700

----------------------------------------------------------------------
 .../apache/spark/sql/execution/streaming/state/StateStore.scala    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/spark/blob/b4066354/sql/core/src/main/scala/org/apache/spark/sql/execution/streaming/state/StateStore.scala
----------------------------------------------------------------------
diff --git 
a/sql/core/src/main/scala/org/apache/spark/sql/execution/streaming/state/StateStore.scala
 
b/sql/core/src/main/scala/org/apache/spark/sql/execution/streaming/state/StateStore.scala
index 9948292..0667653 100644
--- 
a/sql/core/src/main/scala/org/apache/spark/sql/execution/streaming/state/StateStore.scala
+++ 
b/sql/core/src/main/scala/org/apache/spark/sql/execution/streaming/state/StateStore.scala
@@ -115,7 +115,7 @@ case class KeyRemoved(key: UnsafeRow) extends StoreUpdate
  */
 private[sql] object StateStore extends Logging {
 
-  val MAINTENANCE_INTERVAL_CONFIG = 
"spark.streaming.stateStore.maintenanceInterval"
+  val MAINTENANCE_INTERVAL_CONFIG = 
"spark.sql.streaming.stateStore.maintenanceInterval"
   val MAINTENANCE_INTERVAL_DEFAULT_SECS = 60
 
   private val loadedProviders = new mutable.HashMap[StateStoreId, 
StateStoreProvider]()


---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscr...@spark.apache.org
For additional commands, e-mail: commits-h...@spark.apache.org

Reply via email to