This is an automated email from the ASF dual-hosted git repository.

spmallette pushed a commit to branch TINKERPOP-2076
in repository https://gitbox.apache.org/repos/asf/tinkerpop.git

commit 32ef1ef4e8bb642f9af013156b36ad2ce987d180
Author: stephen <spmalle...@gmail.com>
AuthorDate: Tue Nov 12 08:22:14 2019 -0500

    TINKERPOP-2076 More Java 11 documentation updates
---
 README.asciidoc                                         | 2 +-
 docs/src/dev/developer/development-environment.asciidoc | 4 ++--
 docs/src/upgrade/release-3.5.x.asciidoc                 | 8 +++++++-
 3 files changed, 10 insertions(+), 4 deletions(-)

diff --git a/README.asciidoc b/README.asciidoc
index 65d885e..2733047 100644
--- a/README.asciidoc
+++ b/README.asciidoc
@@ -29,7 +29,7 @@ Apache TinkerPop™ provides graph computing capabilities for 
both graph databas
 
 === Building and Testing
 
-TinkerPop uses link:https://maven.apache.org/[Maven] and requires `Java 
1.8.0_40+` for proper building and proper operations. To build, execute unit 
tests and package Gremlin Console/Server run:
+TinkerPop uses link:https://maven.apache.org/[Maven] and requires `Java 11` 
for proper building and proper operations. To build, execute unit tests and 
package Gremlin Console/Server run:
 
 [source,bash]
 mvn clean install
diff --git a/docs/src/dev/developer/development-environment.asciidoc 
b/docs/src/dev/developer/development-environment.asciidoc
index ab5ab63..6eafd87 100644
--- a/docs/src/dev/developer/development-environment.asciidoc
+++ b/docs/src/dev/developer/development-environment.asciidoc
@@ -24,8 +24,8 @@ configure a development environment for TinkerPop.
 [[system-configuration]]
 == System Configuration
 
-At a minimum, development of TinkerPop requires 
link:http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html[Java
 1.8.0_40+]
-and link:https://maven.apache.org/download.cgi[Maven 3.2.5+]. Maven is used as 
the common build system, which even
+At a minimum, development of TinkerPop requires 
link:https://openjdk.java.net/projects/jdk/11/[Java 11]
+and link:https://maven.apache.org/download.cgi[Maven 3.3.9+]. Maven is used as 
the common build system, which even
 controls the builds of non-JVM 
link:https://tinkerpop.apache.org/docs/current/tutorials/gremlin-language-variants/[GLVs]
 such as `gremlin-python`. Java and Maven are described as a "minimum" for a 
development environment, because they
 will only build JVM portions of TinkerPop and many integration tests will not 
fire with this simple setup. It is
diff --git a/docs/src/upgrade/release-3.5.x.asciidoc 
b/docs/src/upgrade/release-3.5.x.asciidoc
index f1b2ee3..c9b1e3c 100644
--- a/docs/src/upgrade/release-3.5.x.asciidoc
+++ b/docs/src/upgrade/release-3.5.x.asciidoc
@@ -29,6 +29,12 @@ Please see the 
link:https://github.com/apache/tinkerpop/blob/3.5.0/CHANGELOG.asc
 
 === Upgrading for Users
 
+==== Java 11
+
+TinkerPop now builds and is compatible with Java 11.
+
+See: link:https://issues.apache.org/jira/browse/TINKERPOP-2076[TINKERPOP-2076]
+
 ==== Gryo Usage
 
 Since the first release of TinkerPop 3.x, Gryo has been the default 
serialization format for Gremlin Server and
@@ -44,7 +50,7 @@ advisable to take this approach.
 
 For best compatibility between 3.4.x and 3.5.x, please use GraphBinary.
 
-link:https://issues.apache.org/jira/browse/TINKERPOP-2259[TINKERPOP-2259]
+See: link:https://issues.apache.org/jira/browse/TINKERPOP-2259[TINKERPOP-2259]
 
 ==== Configuration Upgrade
 

Reply via email to