[
https://issues.apache.org/jira/browse/WICKET-5664?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14087511#comment-14087511
]
ASF subversion and git services commented on WICKET-5664:
---------------------------------------------------------
Commit 09dc961ba7aee5113d31bd5848f036ddf59eacac in wicket's branch
refs/heads/master from [~mgrigorov]
[ https://git-wip-us.apache.org/repos/asf?p=wicket.git;h=09dc961 ]
WICKET-5664 Log a warning if the name of the JavaScript event starts with 'on'
> Log a warning if the name of the JavaScript event starts with 'on'
> -------------------------------------------------------------------
>
> Key: WICKET-5664
> URL: https://issues.apache.org/jira/browse/WICKET-5664
> Project: Wicket
> Issue Type: Task
> Components: wicket
> Affects Versions: 7.0.0-M2
> Reporter: Martin Grigorov
> Assignee: Martin Grigorov
> Priority: Minor
> Fix For: 7.0.0-M3
>
>
> 'onclick' has been used in Wicket 1.5 and older versions as a name of the
> HTML attribute
> Since 6.0.0 Wicket uses event registration (via jQuery#on()) and the leading
> 'on' is no more needed.
> At the moment Wicket cuts the prefix but automatically this disallows usage
> of custom event names like "onmycustomname".
> I suggest to log a warning in 7.x and remove the automatic cut of 'on' in
> Wicket 8.0.
--
This message was sent by Atlassian JIRA
(v6.2#6252)