[
https://issues.apache.org/jira/browse/WICKET-5866?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15388363#comment-15388363
]
ASF subversion and git services commented on WICKET-5866:
---------------------------------------------------------
Commit 651ebeb2245d38f169b012905b05ca2e7672d027 in wicket's branch
refs/heads/master from [~svenmeier]
[ https://git-wip-us.apache.org/repos/asf?p=wicket.git;h=651ebeb ]
WICKET-5866 added #createConverter() without generics parameter for convenience
> Reconsider generics of IConverterLocator#getConverter()
> -------------------------------------------------------
>
> Key: WICKET-5866
> URL: https://issues.apache.org/jira/browse/WICKET-5866
> Project: Wicket
> Issue Type: Improvement
> Components: wicket
> Affects Versions: 7.0.0
> Reporter: Sven Meier
> Assignee: Sven Meier
> Priority: Minor
> Fix For: 8.0.0-M2
>
>
> IConverterLocator#getConverter() has a generic parameter <C> currently.
> It seems to me that this is not very useful: almost all code calling
> #getConverter() does not care for the type parameter.
> From the user perspective it's very common to override
> Component#getConverter(). With the need for a cast and to suppress the
> generics warning, providing a custom converter is much too hard currently:
> {code}
> public <C> IConverter<C> getConverter(Class<C> clazz)
> {
> if (Date.class.isAssignableFrom(clazz))
> {
> @SuppressWarnings("unchecked")
> return (IConverter<C>)new DateConverter();
> }
> else
> {
> return super.getConverter(clazz);
> }
> }
> {code}
> I propose to remove the generics parameter from the method:
> {code}
> public IConverter<?> getConverter(Class<?> clazz)
> {
> if (Date.class.isAssignableFrom(clazz))
> {
> return new DateConverter();
> }
> else
> {
> return super.getConverter(clazz);
> }
> }
> {code}
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)