Kamil created WICKET-6536:
-----------------------------

             Summary: Add generic to MarkupContainer#visitChildren
                 Key: WICKET-6536
                 URL: https://issues.apache.org/jira/browse/WICKET-6536
             Project: Wicket
          Issue Type: Improvement
          Components: wicket
    Affects Versions: 8.0.0-M8
            Reporter: Kamil


currently MarkupContainer#visitChildren has signature:
{code:java}
final <S extends Component, R> R visitChildren(final Class<?> clazz, final 
IVisitor<S, R> visitor){code}
while im my opinion it should have:
{code:java}
final <S extends Component, R> R visitChildren(final Class<S> clazz, final 
IVisitor<S, R> visitor){code}
Why force user to do class cast while we already know which class we pass to 
the method?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to