Repository: hadoop
Updated Branches:
  refs/heads/yarn-native-services 165e50b00 -> 681a3a65d


YARN-5958. Fix ASF license warnings for slider core module. Contributed by 
Billie Rinaldi


Project: http://git-wip-us.apache.org/repos/asf/hadoop/repo
Commit: http://git-wip-us.apache.org/repos/asf/hadoop/commit/681a3a65
Tree: http://git-wip-us.apache.org/repos/asf/hadoop/tree/681a3a65
Diff: http://git-wip-us.apache.org/repos/asf/hadoop/diff/681a3a65

Branch: refs/heads/yarn-native-services
Commit: 681a3a65d1f1fa8272444e8f18a8f16aa0bac526
Parents: 165e50b
Author: Gour Saha <gourks...@apache.org>
Authored: Thu Dec 1 17:45:44 2016 -0800
Committer: Gour Saha <gourks...@apache.org>
Committed: Thu Dec 1 17:45:44 2016 -0800

----------------------------------------------------------------------
 .../hadoop-yarn-slider-core/pom.xml             | 61 +++++---------------
 .../src/license/THIRD-PARTY.properties          | 33 -----------
 2 files changed, 14 insertions(+), 80 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/hadoop/blob/681a3a65/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-slider/hadoop-yarn-slider-core/pom.xml
----------------------------------------------------------------------
diff --git 
a/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-slider/hadoop-yarn-slider-core/pom.xml
 
b/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-slider/hadoop-yarn-slider-core/pom.xml
index 66e9ee9..10cf6b1 100644
--- 
a/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-slider/hadoop-yarn-slider-core/pom.xml
+++ 
b/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-slider/hadoop-yarn-slider-core/pom.xml
@@ -78,6 +78,20 @@
         </executions>
       </plugin>
 
+      <plugin>
+        <groupId>org.apache.rat</groupId>
+        <artifactId>apache-rat-plugin</artifactId>
+        <configuration>
+          <excludes>
+            <exclude>**/*.json</exclude>
+            <exclude>src/main/resources/webapps/slideram/.keep</exclude>
+            <!-- protobuf generated classes -->
+            
<exclude>src/main/java/org/apache/slider/api/proto/Messages.java</exclude>
+            
<exclude>src/main/java/org/apache/slider/api/proto/SliderClusterAPI.java</exclude>
+          </excludes>
+        </configuration>
+      </plugin>
+
     </plugins>
   </build>
   <dependencies>
@@ -384,53 +398,6 @@
       </build>
     </profile>
 
-
-    <profile>
-      <id>rat</id>
-      <build>
-        <plugins>
-
-          <plugin>
-            <groupId>org.apache.rat</groupId>
-            <artifactId>apache-rat-plugin</artifactId>
-            <executions>
-              <execution>
-                <id>check-licenses</id>
-                <goals>
-                  <goal>check</goal>
-                </goals>
-              </execution>
-            </executions>
-            <configuration>
-              <excludes>
-                <exclude>**/*.json</exclude>
-                <exclude>src/test/python/agent.ini</exclude>
-                <exclude>src/test/python/version</exclude>
-                <exclude>**/THIRD-PARTY.properties</exclude>
-                <exclude>src/main/resources/webapps/slideram/.keep</exclude>
-                <exclude>src/main/resources/webapps/slideragent/.keep</exclude>
-                
<exclude>src/main/resources/webapps/static/yarn.dt.plugins.js</exclude>
-                <!-- jQuery DataTables files (BSD license) -->
-                
<exclude>src/main/resources/webapps/static/dt-1.9.4/**</exclude>
-                <!-- jQuery (MIT license) -->
-                
<exclude>src/main/resources/webapps/static/jquery/jquery-1.8.2.min.js</exclude>
-                <!-- jQuery UI (MIT license) -->
-                
<exclude>src/main/resources/webapps/static/jquery/jquery-ui-1.9.1.custom.min.js</exclude>
-                
<exclude>src/main/resources/webapps/static/jquery/themes-1.9.1/base/jquery-ui.css</exclude>
-                <!-- jQuery jsTree (MIT license) -->
-                
<exclude>src/main/resources/webapps/static/jt/jquery.jstree.js</exclude>
-                <!-- protobuf generated classes -->
-                
<exclude>src/main/java/org/apache/slider/api/proto/Messages.java</exclude>
-                
<exclude>src/main/java/org/apache/slider/api/proto/SliderClusterAPI.java</exclude>
-                
<exclude>src/test/app_packages/test_am_config/resources/test.template</exclude>
-                
<exclude>src/test/app_packages/test_am_config/test_archive/testfile</exclude>
-              </excludes>
-            </configuration>
-          </plugin>
-        </plugins>
-      </build>
-    </profile>
-
   </profiles>
 
 </project>

http://git-wip-us.apache.org/repos/asf/hadoop/blob/681a3a65/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-slider/hadoop-yarn-slider-core/src/license/THIRD-PARTY.properties
----------------------------------------------------------------------
diff --git 
a/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-slider/hadoop-yarn-slider-core/src/license/THIRD-PARTY.properties
 
b/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-slider/hadoop-yarn-slider-core/src/license/THIRD-PARTY.properties
deleted file mode 100644
index 1abd56e..0000000
--- 
a/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-slider/hadoop-yarn-slider-core/src/license/THIRD-PARTY.properties
+++ /dev/null
@@ -1,33 +0,0 @@
-# Generated by org.codehaus.mojo.license.AddThirdPartyMojo
-#-------------------------------------------------------------------------------
-# Already used licenses in project :
-# - Apache License
-# - BSD
-# - CDDL + GPLv2 with classpath exception
-# - CDDL 1.1
-# - CDDL License
-# - CDDL+GPL
-# - Common Public License Version 1.0
-# - Eclipse Public License - Version 1.0
-# - GNU Lesser General Public License (LGPL), Version 2.1
-# - GNU Lesser General Public License, Version 2.1
-# - GPL2 w/ CPE
-# - MIT License
-# - MPL 1.1
-# - New BSD License
-# - Public Domain
-# - Revised BSD
-# - The Apache Software License, Version 2.0
-# - The BSD 3-Clause License
-# - The BSD License
-# - The MIT License
-#-------------------------------------------------------------------------------
-# Please fill the missing licenses for dependencies :
-#
-#
-#Thu Oct 15 16:45:02 EDT 2015
-commons-beanutils--commons-beanutils--1.7.0=The Apache Software License, 
Version 2.0
-javax.servlet--servlet-api--2.5=CDDL License
-javax.servlet.jsp--jsp-api--2.1=CDDL License
-org.apache.zookeeper--zookeeper--3.4.6=The Apache Software License, Version 2.0
-org.codehaus.jettison--jettison--1.1=The Apache Software License, Version 2.0


---------------------------------------------------------------------
To unsubscribe, e-mail: common-commits-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-commits-h...@hadoop.apache.org

Reply via email to