Xiao Chen created HADOOP-13641:

             Summary: Update UGI#spawnAutoRenewalThreadForUserCreds to reduce 
                 Key: HADOOP-13641
                 URL: https://issues.apache.org/jira/browse/HADOOP-13641
             Project: Hadoop Common
          Issue Type: Improvement
            Reporter: Xiao Chen
            Priority: Minor

>From [~drankye]'s comment in HADOOP-13590:

Could we return earlier at the beginning so we can avoid at least 2 level of 
indents and make the whole block more readable?
  /**Spawn a thread to do periodic renewals of kerberos credentials*/
  private void spawnAutoRenewalThreadForUserCreds() {
    if (isSecurityEnabled()) {
      //spawn thread only if we have kerb credentials
      if (user.getAuthenticationMethod() == AuthenticationMethod.KERBEROS &&
          !isKeytab) {
                             very deep nested ...

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: common-dev-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-dev-h...@hadoop.apache.org

Reply via email to