[ 
https://issues.apache.org/jira/browse/HADOOP-9565?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15150289#comment-15150289
 ] 

Steve Loughran commented on HADOOP-9565:
----------------------------------------

looking at this —sorry for not doing it earlier. As the initial stuff was my 
code, I'm not qualified to vote it in though.

# I like how you've picked this up for s3a and swift
# I think we're going to have to cover azure. Which sort-of has atomic renames 
(it has renames, they're just not always O(1). I don't know if we can/should 
include complexity of operation into the bitmap. If so, cost of close(), 
open(), flush().
# and I think we should add a couple of bits for "supports append" and 
"flush-saves data"; if false it means that nothing gets written until the end.

As a follow on from this, I'd like to have something in FileContext too. Even 
with a separate patch, we ought to be able to share structures, the constants. 
The problem we have there is FileContext is its own thing that relays to the 
(hidden) AbstractFilesystem subclass. I think we'd need to have a subclass of 
FileContext which indicates this, or we make publishing FS semantics something 
common to all filesystems/file contexts. Thoughts?



> Add a Blobstore interface to add to blobstore FileSystems
> ---------------------------------------------------------
>
>                 Key: HADOOP-9565
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9565
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: fs, fs/s3, fs/swift
>    Affects Versions: 2.6.0
>            Reporter: Steve Loughran
>            Assignee: Thomas Demoor
>              Labels: BB2015-05-TBR
>         Attachments: HADOOP-9565-001.patch, HADOOP-9565-002.patch, 
> HADOOP-9565-003.patch, HADOOP-9565-004.patch, HADOOP-9565-005.patch
>
>
> We can make the fact that some {{FileSystem}} implementations are really 
> blobstores, with different atomicity and consistency guarantees, by adding a 
> {{Blobstore}} interface to add to them. 
> This could also be a place to add a {{Copy(Path,Path)}} method, assuming that 
> all blobstores implement at server-side copy operation as a substitute for 
> rename.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to