[
https://issues.apache.org/jira/browse/HADOOP-12563?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15236011#comment-15236011
]
Ravi Prakash commented on HADOOP-12563:
---------------------------------------
Thanks for the patch and all your work Matt! Thanks also for your reviews and
guidance Steve! I see that this patch has come a long way
# Could you please file and patch a follow-on JIRA for adding documentation.
Perhaps here :
https://github.com/apache/hadoop/blob/trunk/hadoop-common-project/hadoop-common/src/site/markdown/CommandsManual.md
# Do you think it'd be good to create an Enum for different versions? {code}
if (version == 0) {
readFields(in);
} else if (version == 1) {
readProtos(in);
}{code}
# Do you know if there would be any difference between
{{CredentialsKVProto.newBuilder().setAlias(e.getKey().toString())}} and what
you have
({{CredentialsKVProto.newBuilder().setAliasBytes(ByteString.copyFrom(e.getKey().getBytes(),
0, e.getKey().getLength()))}}) ? Would one be encoded/decoded differently on
varying platforms? Looking into the generated code, I see in one case
{{alias_}} would be an {{Object}} of type {{String }} vs {{ByteString}} in the
other case. I guess the deviation may only be in the case when the encoding is
different than UTF-8 . Do you know if we should prefer one way over the other?
# Could {{setKindBytes(ByteString.copyFrom(this.getKind().getBytes(), 0,
this.getKind().getLength()))}} simply be
{{setKindBytes(ByteString.copyFrom(this.getKind().getBytes()))}}?
> Updated utility to create/modify token files
> --------------------------------------------
>
> Key: HADOOP-12563
> URL: https://issues.apache.org/jira/browse/HADOOP-12563
> Project: Hadoop Common
> Issue Type: New Feature
> Affects Versions: 3.0.0
> Reporter: Allen Wittenauer
> Assignee: Matthew Paduano
> Attachments: HADOOP-12563.01.patch, HADOOP-12563.02.patch,
> HADOOP-12563.03.patch, HADOOP-12563.04.patch, HADOOP-12563.05.patch,
> HADOOP-12563.06.patch, HADOOP-12563.07.patch, HADOOP-12563.07.patch,
> HADOOP-12563.08.patch, HADOOP-12563.09.patch, dtutil-test-out,
> dtutil_diff_07_08, example_dtutil_commands_and_output.txt,
> generalized_token_case.pdf
>
>
> hdfs fetchdt is missing some critical features and is geared almost
> exclusively towards HDFS operations. Additionally, the token files that are
> created use Java serializations which are hard/impossible to deal with in
> other languages. It should be replaced with a better utility in common that
> can read/write protobuf-based token files, has enough flexibility to be used
> with other services, and offers key functionality such as append and rename.
> The old version file format should still be supported for backward
> compatibility, but will be effectively deprecated.
> A follow-on JIRA will deprecrate fetchdt.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)