[
https://issues.apache.org/jira/browse/HADOOP-13077?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15265361#comment-15265361
]
Allen Wittenauer commented on HADOOP-13077:
-------------------------------------------
Thanks.
This gives us a chance to clean this up:
* any reason why this is using multiple seds instead of just one using -e?
multiple seds are expensive...
* this should be in hadoop-functions.sh and have both kms.sh and httpfs.sh call
it. this removes some code redundancy and allows us to write a unit test, thus
eliminating the need to have a tar ball to reproduce
* when it gets moved to hadoop-functions, probably better to rename it to
something like hadoop_xml_passescape or whatever. (hadoop_escape is pretty
generic)
> Handle special characters in passwords in httpfs.sh
> ---------------------------------------------------
>
> Key: HADOOP-13077
> URL: https://issues.apache.org/jira/browse/HADOOP-13077
> Project: Hadoop Common
> Issue Type: Bug
> Affects Versions: 3.0.0
> Reporter: Xiao Chen
> Assignee: Xiao Chen
> Attachments: HADOOP-13077-repro.tar.gz, HADOOP-13077.01.patch
>
>
> As [~aw] pointed out in [this
> comment|https://issues.apache.org/jira/browse/HADOOP-13030?focusedCommentId=15262439&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-15262439],
> need a similar fix to this script.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]