Kai Zheng commented on HADOOP-13061:

It looks much close now. Some minors:
* AbstractErasureCodec => ErasureCodec, and in the class, ecCodecOptions => 
codecOptions, ecCoderOptions => coderOptions, also the related methods.
* Maybe a package-info.java in the codec package?
* Class comments for DummyErasureEncoder/DummyErasureDecoder could be refined;
* Class comments for CodecUtil could be refined and more accurate now;
* In CodecUtil#getCodecName, it should be {{getCodecClassName}} instead. It can 
just return the current codec class name (instead of from configuration), 
because we don't configure codec impl, instead we configure raw coder impl for 
a codec. Given a codec name, we can safely return the codec class.

+1 once above addressed. Thanks!

> Refactor erasure coders
> -----------------------
>                 Key: HADOOP-13061
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13061
>             Project: Hadoop Common
>          Issue Type: Sub-task
>            Reporter: Rui Li
>            Assignee: Kai Sasaki
>         Attachments: HADOOP-13061.01.patch, HADOOP-13061.02.patch, 
> HADOOP-13061.03.patch, HADOOP-13061.04.patch, HADOOP-13061.05.patch, 
> HADOOP-13061.06.patch, HADOOP-13061.07.patch, HADOOP-13061.08.patch, 
> HADOOP-13061.09.patch, HADOOP-13061.10.patch

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org

Reply via email to