[ 
https://issues.apache.org/jira/browse/HADOOP-13583?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Andrew Wang updated HADOOP-13583:
---------------------------------
    Attachment: HADOOP-13583.003.patch

Thanks for the review Robert, changes in new patch:

* Removed the unused variable.
* Whitespace is spurious since it's in a comment. It's an example of output 
from the git command, which has tabs.
* I ran pylint locally with the google style guide. I like the single-letter 
vars for short for loops, and I left main as is though it's long. Here's the 
pylint output:

{noformat}
C:  1, 0: Missing module docstring (missing-docstring)
C:143,27: Invalid variable name "w" (invalid-name)
C:164,27: Invalid variable name "f" (invalid-name)
C:195,40: Invalid variable name "f" (invalid-name)
C:209, 8: Invalid variable name "f" (invalid-name)
C:222, 8: Invalid variable name "f" (invalid-name)
C:286, 8: Invalid variable name "f" (invalid-name)
C:294, 8: Invalid variable name "f" (invalid-name)
C:302, 8: Invalid variable name "a" (invalid-name)
R:234, 0: Too many branches (13/12) (too-many-branches)
R:234, 0: Too many statements (55/50) (too-many-statements)
....
Your code has been rated at 9.39/10 (previous run: 9.18/10, +0.22)
{noformat}

I can fix these too if you want, but I think it's pretty readable in its 
current state.

> Incorporate checkcompatibility script which runs Java API Compliance Checker
> ----------------------------------------------------------------------------
>
>                 Key: HADOOP-13583
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13583
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: scripts
>    Affects Versions: 2.6.4
>            Reporter: Andrew Wang
>            Assignee: Andrew Wang
>         Attachments: HADOOP-13583.001.patch, HADOOP-13583.002.patch, 
> HADOOP-13583.003.patch
>
>
> Based on discussion at YETUS-445, this code can't go there, but it's still 
> very useful for release managers. A similar variant of this script has been 
> used for a while by Apache HBase and Apache Kudu, and IMO JACC output is 
> easier to understand than JDiff.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org

Reply via email to