[ 
https://issues.apache.org/jira/browse/HADOOP-14693?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16120328#comment-16120328
 ] 

Ajay Yadav commented on HADOOP-14693:
-------------------------------------

 [~ajisakaa],[~andrew.wang] , As i understand , we can do it in two ways.
1. Update the junit dependency in hadoop-main to junit5 with 
junit-jupiter-engine. which will require changes in most of the test cases to 
move them to new junit5 api and platform. (More riskier)
2. Update the junit dependency in hadoop-main to junit5 while maintaining 
backward compatibility to test cases built in junit4 using 
(junit-vintage-engine). As a next step we can create new test cases using junit 
5 api and move old test cases to junit5 in steps. This will be incremental 
change with less risk to breaking old test cases.
Any ideas, suggestions on this?

> Upgrade JUnit from 4 to 5
> -------------------------
>
>                 Key: HADOOP-14693
>                 URL: https://issues.apache.org/jira/browse/HADOOP-14693
>             Project: Hadoop Common
>          Issue Type: Sub-task
>            Reporter: Akira Ajisaka
>
> JUnit 4 does not support Java 9. We need to upgrade this.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org

Reply via email to