[ 
https://issues.apache.org/jira/browse/HADOOP-15375?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16431571#comment-16431571
 ] 

Íñigo Goiri commented on HADOOP-15375:
--------------------------------------

Thanks [~xiaochen], hopefully we should have a branch-2 build tomorrow.

> Branch-2 pre-commit failed to build docker image
> ------------------------------------------------
>
>                 Key: HADOOP-15375
>                 URL: https://issues.apache.org/jira/browse/HADOOP-15375
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 2.10.0
>            Reporter: Xiao Chen
>            Assignee: Xiao Chen
>            Priority: Major
>             Fix For: 2.10.0, 2.9.2
>
>         Attachments: HADOOP-15375.branch-2.00.patch
>
>
> Branch-2 pre-commit is failing during {{Building base image}}:
> {noformat}
> ...
> Step 28/33 : RUN apt-get -y install nodejs &&     ln -s /usr/bin/nodejs 
> /usr/bin/node &&     apt-get -y install npm &&     npm set ca null &&     npm 
> install -g bower &&     npm install -g ember-cli
> {noformat}
> {noformat}
> ...
> Setting up npm (1.3.10~dfsg-1) ...
> npm http GET 
> [https://registry.npmjs.org/bower]
> npm http GET 
> [https://registry.npmjs.org/bower]
> npm http GET 
> [https://registry.npmjs.org/bower]
> npm ERR! Error: CERT_UNTRUSTED
> npm ERR!     at SecurePair.<anonymous> (tls.js:1370:32)
> npm ERR!     at SecurePair.EventEmitter.emit (events.js:92:17)
> npm ERR!     at SecurePair.maybeInitFinished (tls.js:982:10)
> npm ERR!     at CleartextStream.read [as _read] (tls.js:469:13)
> npm ERR!     at CleartextStream.Readable.read (_stream_readable.js:320:10)
> npm ERR!     at EncryptedStream.write [as _write] (tls.js:366:25)
> npm ERR!     at doWrite (_stream_writable.js:223:10)
> npm ERR!     at writeOrBuffer (_stream_writable.js:213:5)
> npm ERR!     at EncryptedStream.Writable.write (_stream_writable.js:180:11)
> npm ERR!     at write (_stream_readable.js:583:24)
> npm ERR! If you need help, you may report this log at:
> npm ERR!     <
> [http://github.com/isaacs/npm/issues]
> >
> npm ERR! or email it to:
> npm ERR!     <n...@googlegroups.com>
> npm ERR! System Linux 3.13.0-143-generic
> npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install" "-g" "bower"
> npm ERR! cwd /root
> npm ERR! node -v v0.10.25
> npm ERR! npm -v 1.3.10
> npm ERR! 
> npm ERR! Additional logging details can be found in:
> npm ERR!     /root/npm-debug.log
> npm ERR! not ok code 0
> {noformat}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org

Reply via email to