[ 
https://issues.apache.org/jira/browse/HADOOP-12527?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16434551#comment-16434551
 ] 

Aaron Tokhy commented on HADOOP-12527:
--------------------------------------

It appears that the Hadoop 2.9.x/Hadoop 3.x branches have moved to Avro 1.7.7.

> Upgrade Avro dependency to 1.7.7 or later
> -----------------------------------------
>
>                 Key: HADOOP-12527
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12527
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: build
>    Affects Versions: 2.7.1
>            Reporter: Jonathan Kelly
>            Assignee: Sean Busbey
>            Priority: Major
>
> Hadoop has depended upon Avro 1.7.4 for a couple of years now (see 
> HADOOP-9672), but Apache Spark depends upon what is currently the latest 
> version of Avro (1.7.7).
> This can cause issues if Spark is configured to include the full Hadoop 
> classpath, as the classpath would then contain both Avro 1.7.4 and 1.7.7, 
> with the 1.7.4 classes possibly winning depending on ordering. Here is an 
> example of this issue: 
> http://stackoverflow.com/questions/33159254/avro-error-on-aws-emr/33403111#33403111
> Would it be possible to upgrade Hadoop's Avro dependency to 1.7.7 now?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org

Reply via email to