[ 
https://issues.apache.org/jira/browse/HADOOP-10075?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13827956#comment-13827956
 ] 

Colin Patrick McCabe commented on HADOOP-10075:
-----------------------------------------------

Thanks for looking at this.  I think you will need to re-generate the patch, 
since it failed to apply on jenkins.

{code}
--- 
a/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/http/TestSSLHttpServer.java
+++ 
b/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/http/TestSSLHttpServer.java
@@ -76,6 +76,7 @@ public void setup() throws Exception {
 
     conf.setInt(HttpServer.HTTP_MAX_THREADS, 10);
     conf.addResource(CONFIG_SITE_XML);
+    conf.addResource(conf.get("hadoop.ssl.server.conf","ssl-server.xml"));
     server = createServer("test", conf);
     server.addServlet("echo", "/echo", TestHttpServer.EchoServlet.class);
     server.start();
{code}

Why do we need this addition?

{code}
-        InetAddress.getByName(server.getConnectors()[0].getHost());
-      int port = server.getConnectors()[0].getPort();
+        
InetAddress.getByName(((ServerConnector)server.getConnectors()[0]).getHost());
+      int port = ((ServerConnector)server.getConnectors()[0]).getPort();
{code}

I see a lot of new typecasts like this.  Is it possible to avoid these?  If 
not, could we have an accessor function that makes this easier to read?  Thanks.

> Update jetty dependency to version 9
> ------------------------------------
>
>                 Key: HADOOP-10075
>                 URL: https://issues.apache.org/jira/browse/HADOOP-10075
>             Project: Hadoop Common
>          Issue Type: Improvement
>    Affects Versions: 2.2.0
>            Reporter: Robert Rati
>            Assignee: Robert Rati
>         Attachments: HADOOP-10075.patch
>
>
> Jetty6 is no longer maintained.  Update the dependency to jetty9.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Reply via email to