Akira AJISAKA created HADOOP-11440:
--------------------------------------
Summary: Use "test.build.dir" instead of "build.test.dir" for
testing in ClientBaseWithFixes
Key: HADOOP-11440
URL: https://issues.apache.org/jira/browse/HADOOP-11440
Project: Hadoop Common
Issue Type: Improvement
Affects Versions: 2.6.0
Reporter: Akira AJISAKA
Priority: Minor
In ClientBaseWithFixes.java, the base directory for tests are set in the
following:
{code}
static final File BASETEST =
new File(System.getProperty("build.test.dir", "build"));
{code}
There is no property "build.test.dir", so {{BASETEST}} is always "build". We
should use "test.build.dir" instead of "build.test.dir".
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)