[
https://issues.apache.org/jira/browse/HADOOP-11746?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Allen Wittenauer updated HADOOP-11746:
--------------------------------------
Attachment: HADOOP-11746-18.patch
-18:
* add --modulelist and --testlist options to forcibly add modules and test
subsystems to a run. there is no way to delete, but that's probably a good
thing really.
* removed the branch restrictions since this apparently won't impact jenkins
* the check for new tests actually uses the /test/ file path against the list
of changed files in the check for new tests in unit test mode. This prevents
some false positives and should improve the count in certain/rare situations.
Prior to this, it just looked for (something)/test(something) in the actual
patch... which meant test-patch itself would be cleared. (Ironically,
test-patch.sh is now capable of testing itself, so ... yeah. test-ception.)
* in developer mode when --resetrepo is used, the user output reminds that the
code the user chose to run in a destructive mode. (--resetrepo is the default
in jenkins mode, obviously)
* Added code to chmod +x all directories in echo_and_redirect. This should
cover every maven run.
* Cleaned up the eclipse description.
* Checkstyle now uses the ${PROJECT_NAME} var instead of the hard coded hadoop
value, making the code more portable.
* Reworded some debug output for test subsystems when they are triggered
* verify_needed_test was missing documentation
bq. Adding audience / stability comments is a really nice touch.
Thanks. If you run shelldoc.py (after HADOOP-11845 is applied... ugh) against
the code, you'll get a markdown document of the function calls. We're currently
using this same functionality in trunk to document hadoop-functions.sh as the
'official' shell API for shell profiles.
> rewrite test-patch.sh
> ---------------------
>
> Key: HADOOP-11746
> URL: https://issues.apache.org/jira/browse/HADOOP-11746
> Project: Hadoop Common
> Issue Type: Test
> Components: build, test
> Affects Versions: 3.0.0
> Reporter: Allen Wittenauer
> Assignee: Allen Wittenauer
> Attachments: HADOOP-11746-00.patch, HADOOP-11746-01.patch,
> HADOOP-11746-02.patch, HADOOP-11746-03.patch, HADOOP-11746-04.patch,
> HADOOP-11746-05.patch, HADOOP-11746-06.patch, HADOOP-11746-07.patch,
> HADOOP-11746-09.patch, HADOOP-11746-10.patch, HADOOP-11746-11.patch,
> HADOOP-11746-12.patch, HADOOP-11746-13.patch, HADOOP-11746-14.patch,
> HADOOP-11746-15.patch, HADOOP-11746-16.patch, HADOOP-11746-17.patch,
> HADOOP-11746-18.patch
>
>
> This code is bad and you should feel bad.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)