[ 
https://issues.apache.org/jira/browse/HADOOP-7891?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14524570#comment-14524570
 ] 

Hadoop QA commented on HADOOP-7891:
-----------------------------------

\\
\\
| (x) *{color:red}-1 overall{color}* |
\\
\\
|| Vote || Subsystem || Runtime || Comment ||
| {color:red}-1{color} | patch |   0m  0s | The patch command could not apply 
the patch during dryrun. |
\\
\\
|| Subsystem || Report/Notes ||
| Patch URL | 
http://issues.apache.org/jira/secure/attachment/12546163/HADOOP-7891.patch |
| Optional Tests | javadoc javac unit findbugs checkstyle |
| git revision | trunk / f1a152c |
| Console output | 
https://builds.apache.org/job/PreCommit-HADOOP-Build/6262/console |


This message was automatically generated.

> KerberosName method typo and log warning when rules are set
> -----------------------------------------------------------
>
>                 Key: HADOOP-7891
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7891
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: security
>    Affects Versions: 0.23.1
>            Reporter: Alejandro Abdelnur
>            Assignee: Alejandro Abdelnur
>            Priority: Minor
>         Attachments: HADOOP-7891.patch
>
>
> The method hasRulesBeenSet() should be named haveRulesBeenSet()
> if the rules setting is not done during UGI initialization because they have 
> been already set, a warning should be logged. Along the following lines:
>   "Not setting kerberos name mappings defined in 
> hadoop.security.auth_to_local because name mappings are already set")



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to