[ 
https://issues.apache.org/jira/browse/HADOOP-7891?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14741203#comment-14741203
 ] 

Steve Loughran commented on HADOOP-7891:
----------------------------------------

Are we confident that the method is *never* called by external code? As if not, 
the old method should be retained at deprecated, while the rest of the patch 
goes through

> KerberosName method typo and log warning when rules are set
> -----------------------------------------------------------
>
>                 Key: HADOOP-7891
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7891
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: security
>    Affects Versions: 0.23.1
>            Reporter: Alejandro Abdelnur
>            Assignee: Alejandro Abdelnur
>            Priority: Minor
>              Labels: BB2015-05-TBR
>         Attachments: HADOOP-7891.patch, HADOOP-7891_1.patch
>
>
> The method hasRulesBeenSet() should be named haveRulesBeenSet()
> if the rules setting is not done during UGI initialization because they have 
> been already set, a warning should be logged. Along the following lines:
>   "Not setting kerberos name mappings defined in 
> hadoop.security.auth_to_local because name mappings are already set")



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to