[ http://issues.apache.org/jira/browse/IO-86?page=all ]

Niall Pemberton updated IO-86:
------------------------------

    Attachment: io-DirectoryWalker-cancellation-3.patch

OK I don't buy the jar size argument :) - but the second point about ignoring 
cancellation requests is valid, which is why I proposed removing those checks 
and the isCancelled() method. You're right though it doesn't leave much - 
except a bit of plumbing that makes it slightly easier for people to implement.

What CancellationException gives you is 1) The ability to trap that behaviour 
and 2) extend the behaviour to pass additional info to the handleCancelled() 
method. I also think that using an exception improves the 
readability/simplicity of the class and gives people the option to choose where 
in the DirectoryWalker structure to implement cancellation decision logic.

Following your comments about exceptions I now think we sould add IOException 
to every method and have the cancel exception extend IOException.

Attaching a patch with what I'd like to see it look like - haven't updated the 
class javadocs or tests, will do if this gets agreement.

> Add DirectoryWalker based on FileFinder
> ---------------------------------------
>
>                 Key: IO-86
>                 URL: http://issues.apache.org/jira/browse/IO-86
>             Project: Commons IO
>          Issue Type: New Feature
>          Components: Utilities
>    Affects Versions: 1.2
>            Reporter: Niall Pemberton
>             Fix For: 1.3
>
>         Attachments: FileFinder.java, FileFinderTestCase.java, 
> io-DirectoryWalker-cancellation-3.patch, io-filefinder-start-end.patch
>
>
> I'd like to propose adding a "FileFinder" back into Commons IO. This is a 
> simplified version of what was recently moved out of Commons IO into the 
> "finder" component currently in the sandbox.
> I believe this is a simpler, more generic implementation than the finder 
> component and therefore would be considered suitable for inclusion in Commons 
> IO. Although simpler it could be used as the basis for achieving the finder 
> component's aims - namely to emulate the unix find command.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: 
http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to