Hello. I have a big problem: i cannot read a new 8Gb SD card from Sandisk.

some details:

- the 512 Mb card works without any problem, i've been able to reformat it,
use ext2 on it, mount /usr in it
- i have partitioned the 8Gb card from my pc card reader and i've put a
kernel and a rootfs inside it as the wiki explain
- my FR card slot have got a little capacitor soldered between 2 pins, like
in this image (
http://makovey.objectis.net/Members/dimon/issues/om/microSD2.jpg/view) , but
with better soldering
- during all the experiments i never suspended-resumed the phone, and i am
sure the partitions in the card are not corrupted (because i checked them
periodically with the card reader)

- the boot loader see the card, and is able to load a kernel from it!
(in NAND menu)
$ cu -l /dev/ttyACM0
In:    usbtty
Out:   usbtty
Err:   usbtty
Unrecognized hardware revision 0x305. Defaulting to GTA02v6.
PCB rev: 0x305
Power: 0mA
GTA02v6 # mmcinit
Card Type:          SD 2.0 SDHC
Manufacturer:       0x03, OEM "SD"
Product name:       "SU08G", revision 8.0
Serial number:      554005576
Manufacturing date: 8/2008
MMC/SD size:        3MiB

All the output that follows is taken after booting from the internal flash,
just with the memory card inserted.
If instead i boot from the sd i noticed a strange behaviour: the first try
it sometimes fail to read the card, but the second try it works good, it
loads the kernel and the kernel output is exactly the same of the one below,
except it ends in a kernel panic not finding his root.

# uname -a
Linux roby-neo 2.6.24 #1 PREEMPT Wed Sep 3 19:01:18 CST 2008 armv4tl unknown

# cat /proc/cmdline
glamo_mci.sd_idleclk=1 glamo_mci.sd_max_clk=5000000 rootdelay=5
rootfstype=jffs2 root=/dev/mtdblock6 console=ttySAC2,115200 console=tty0
loglevel=8 regular_boot

- i tried to set just the sd_max_clk to the values
(default,10000000,8333333,5000000), i tried to set the sd_idleclk to 1 or to
0, with the sd_drive at 3 or 0 (doesn't know what's the effect).. nothing,
always the same errors.
- kernel output: (the relevant part, the complete one is attached)

[    3.230000] *mmc0: new high speed SDHC card at address 8fe4*
[    3.270000] neo1973-pm-gps neo1973-pm-gps.0: FIC Neo1973 GPS Power
[    3.335000] Bluetooth: HCI USB driver ver 2.9
[    3.340000] usbcore: registered new interface driver hci_usb
[    3.350000] mmcblk0: mmc0:8fe4 *SU08G 7761920KiB*
[    3.355000]  mmcblk0:<6>glamo-mci glamo-mci.0:* Error after cmd: 0x8310*
[    3.370000] mmcblk0:* error -110* sending read/write command
[    3.375000] end_request: I/O error, dev mmcblk0, sector 0
[    3.375000] Buffer I/O error on device mmcblk0, logical block 0
[    3.380000] glamo-mci glamo-mci.0:* Error after cmd: 0x20*
[    3.385000] glamo-mci glamo-mci.0: *Error after cmd: 0x122*
[    3.390000] mmcblk0: *error -84* sending read/write command
[    3.395000] end_request: I/O error, dev mmcblk0, sector 0
[    3.395000] Buffer I/O error on device mmcblk0, logical block 0
[    3.400000]  *unable to read partition table*
[    3.410000] S3c2440 SDIO Host controller
[    3.515000] pnp: the driver 'sdio_s3c24xx_hcd' has been registered

Please, tell me that i can solve this problem! actually i'm sure it can be
solved, because the boot loader is perfectly (nearly) able to read and load
the kernel written in the sd.
Tell me if some other kind output could be useful.. maybe my shoes number?


Attachment: boot-log-5Mhz.gz
Description: GNU Zip compressed data

Openmoko community mailing list

Reply via email to