Hi Nicola,

On Saturday, September 27, 2008 08:13:18 Nicola Mfb wrote:
> That's very nice, Kelvie.
> I'm still trying to get a working and safe oetree with qt library inside
> :). The first time i tried with the org.openembedded.dev branch and my
> typical angstrom configured local.conf file, but it got a compilation error
> on uicmoc4-native. After that i tried with the fso openmoko conf file, it
> failed again but i noted that the preferred version of qt4 there was 4.3.3
> instead of 4.4.1. I remembered that in org.openembedded.stable there was
> 4.3.3 version, so i tried again with the stable branch. It compiled fine
> but did not create all the requested ipk (empty). I managed a bit on the
> qt_packaging.inc recipie and finally i got a working qt-oe-tree, i was able
> to compile a my application too. I bitbaked the last fso unstable image and
> flashed the phone with it, setupped a fake feed server on my oe tree, added
> it to feeds on the phone and did opkg update, opkg install qt4-x11-free,
> opkg install my-application, and after that i was able to start it adding a
> simple DISPLAY=:0.
> But i'm not very happy of this as it's not simple and i do not like to mix
> different branches.
> Please share your experience on this...

Next time try separating your text into shorter paragraphs, it's easier to 
read :)

I hadn't encountered any of these problems -- I got python-pyqt built against 
the org.openembedded.stable tree (that is, the 4.3.3 version), and installed 
qt4-x11-free-4.4.1 (from angstrom).  They are still binary compatible, and it 
just worked on my Neo, except for the fact that I have to make sure 
LD_LIBRARY_PATH doesn't point to /opt/Qtopia first before starting python (as 
their libraries have the same name, and most of the same functions, but are 
missing some symbols such as QX11EmbedWidget).

Kelvie Wong
Openmoko community mailing list

Reply via email to