Hi Nicola,

I've sent some patches to our distro team and OE can use bitbake to
build the latest qt4-x11-free to version 4.4.1. Since people from
community like to try qt4 new features, I will send an email to our
distro and they would help to put these packages to our feed. Then you
can install them from installer, no need to build it by yourself.

Also, not sure what you are interested in qt4? i am trying webkit
features by python-pyqt.


Nicola Mfb wrote:
> I'm still trying to get a working and safe oetree with qt library inside :).
> The first time i tried with the org.openembedded.dev branch and my
> typical angstrom configured local.conf file, but it got a compilation
> error on uicmoc4-native. After that i tried with the fso openmoko conf
> file, it failed again but i noted that the preferred version of qt4
> there was 4.3.3 instead of 4.4.1. <http://4.4.1.> I remembered that in
> org.openembedded.stable there was 4.3.3 version, so i tried again with
> the stable branch. It compiled fine but did not create all the requested
> ipk (empty). I managed a bit on the qt_packaging.inc recipie and finally
> i got a working qt-oe-tree, i was able to compile a my application too.
> I bitbaked the last fso unstable image and flashed the phone with it,
> setupped a fake feed server on my oe tree, added it to feeds on the
> phone and did opkg update, opkg install qt4-x11-free, opkg install
> my-application, and after that i was able to start it adding a simple
> But i'm not very happy of this as it's not simple and i do not like to
> mix different branches.
> Please share your experience on this...
> Regards
>      Nicola

Openmoko community mailing list

Reply via email to