D. Gassen wrote:
> Am Nov 25, 2009 um 17:07  schrieb Fox Mulder:
>> Carsten Gerlach wrote:
>>> Hello at all,
>>> sorry for this crosspost, but I think this topic is for both list 
>>> interesting.
>>> Today I flashed the new SHR-Image (lite) from 24. nov. 2009 on my 
>>> freerunner, 
>>> and installed the latest svn version from navit, 2797.
>>> At the start of navit I get this error message:
>>> ===============================================
>>> vehicle_gpsd:vehicle_gpsd_try_open:Trying to connect to localhost:default
>>> vehicle_gpsd:vehicle_gpsd_try_open:Warning: gps_fd is 0, most likely you 
>>> have 
>>> used a gps.h incompatible to 
>>> libgpsvehicle_gpsd:vehicle_gpsd_try_open:Connected to gpsd fd=0 
>>> evwatch=0xaa3e0
>>> navit:main_real:Using '/home/root/.navit/navit.xml'
>>> ===============================================
>>> In general the gps is working, tested with tangogps. Only navit doesn't see 
>>> the gps.
>>> What can I do to solve this problem? If any further information is needed, 
>>> I'll try to give my best. :-)
>> I'm at the same error right now. I tried different settings but nothing
>> helped. Now i wanted to compile navit on the freerunner myself but
>> within the shr feeds are not all required packages to do so. And i don't
>> know how to cross-compile it on my pc. :/
>> Gps works right with tangogps, omgps and advanced-geocaching-tool so it
>> have to be something with navit. I have the latest 2797 version from [1]
>> installed and not the one in the shr feeds. I also linked libgps.so.17
>> to libgps.so.16. When i look in my current position navit shows
>> something with 832° in front which is a bit off my current position. ;)
> Have you tried (re)starting fso-gpsd?
> AFAIK, tangogps, omgps and advanced-geocaching-tool are all using gypsy and 
> navit is still using gpsd (and fso-gpsd is a compatibility daemon).
> I sometimes had the same problem and each time fso-gpsd was not running. It 
> should normally be started when the system boots but I found that sometimes 
> it was'nt running when navit tries to use it.

Tanogps uses gpsd, so this could not be the problem.
But now i tried by accident (opkg update downgraded navit r2797 to shr-u
version r2735) the navit version in the shr repository (r2735) and this
version works and connects to the gps without problems. I also can see
my correct position on the map. So it seems that the precompiled
binaries from the navit homepage for the openmoko are not compatible
with current shr-u. Tomorrow i will try to contact someone from the
navit projects and say this so maybe we can find out where the problem
lies. Because i like to have the newest one and not the one from the
shr-u repository. :)


Openmoko community mailing list

Reply via email to