On Tuesday 24 May 2011 12:18:05 Xavier Cremaschi wrote:

> Hi folks,
> is there any way to force usb charging in QtMoko ?
> 
> As there is no support for usb networking with Windows 7 (it seems to be
> disabled in QtMoko kernel), my Freerunner only gets 100ma while being
> plugged on my workplace computer through USB.

I think RNDIS should be enabled, but i havent tried it for very long time and 
IIRC it worked only with winxp.

> How can I force it to gets 500ma ? As QtMoko (v35) seems to consume a
> bit more battery than my old SHR, I would like to be able to charge it
> during the day (without bringing the charger).

If you put the phone to sleep, it should draw like 14mA, so you can charge 
with 86mA.

> Any idea ? I've spotted a "Fast charge mod" in the upper left menu (the
> one full of icons) but it seems to do nothing.

It's one of the original scripts from Qt Extended/Qtopia. I think the sysfs 
paths have changed since then.

If you try om utility (from omhacks package) it could have parameter for 
enabling fast charge. Then you can edit the "Fast charge mode" script so that 
it uses "om" command (and send the result to me so that i can commit it as 
patch ;-).

Regards

Radek

_______________________________________________
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community

Reply via email to