On Wednesday, May 02, 2012 11:04:54 PM francesco.dev...@mailoo.org wrote:

> Il 02/05/2012 18:29, Brian ha scritto:
> > I'd be willing to bet it's something to do with your Qi setup or the SD
> > card setup as IIRC Qi polls the SD card first for a bootable partition
> > and only then boots from NAND.

I think so too. IIRC i tried v44 from SD card and it worked, but i am now not 
100% sure.

> Maybe it is my SD card that is broken. I tried Qi from QtMoko v38 and
> v44, installed QtMoko v38 and v44 on the SD, formatted the SD more than a
> time, I am able to mount it (both on my pc and my GTA02), read and
> write it, no errors shown by disk checks, but still no boot.
> 
> Because Qi doesn't show any output I cannot say what is going
> on. Maybe I can use uboot but I don't know the parameters to select

If POWER button is holded during qi initialization, it should make kernel more 
verbose. Maybe there will be something interesting. You can also play with 
/boot/append-GTA02 file and try rootdelay=10 instead of rootwait if that help.
 
Regards

Radek

_______________________________________________
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community

Reply via email to