On 01/22/2015 09:11 PM, Robert 'Bobby' Zenz wrote:

Thank you. The contacts are on the SIM card, I already tried
"talking" with it but my tries were a little unsuccessful and resulted
in the modem/SIM not answering at all and locking up. My assumption was
that that was because I tried to talk with it at the same time as
QtMoko and its services.

Do you know what the preferred way is to send commands to the SIM in
QtMoko? Or should a "normal" serial/terminal communication program be

You should stop qpe, so it is not using the modem anymore.
( /etc/init.d//qpe/.sh /stop/ i believe )
Then you can use a normal terminal program to send commands.
Minicom should work just fine.

If the modem locks up, you can reset it with:
echo 0 > /sys/devices/platform/s3c2440-i2c/i2c-0/0-0073/pcf50633-gpio.0/reg-fixed-voltage.1/gta02-pm-gsm.0/power_on
sleep 5
echo 1 > /sys/devices/platform/s3c2440-i2c/i2c-0/0-0073/pcf50633-gpio.0/reg-fixed-voltage.1/gta02-pm-gsm.0/power_on

if /sys/devices/platform/s3c2440-i2c/i2c-0/0-0073/pcf50633-gpio.0/reg-fixed-voltage.1/gta02-pm-gsm.0/power_on
does not exists, try
/sys/devices/platform/s3c2440-i2c/i2c-adapter/i2c-0/0-0073/neo1973-pm-gsm.0/power_on, there was a change of path somewhere in the past.

Kind regards,

Openmoko community mailing list

Reply via email to