Send connman mailing list submissions to
        connman@lists.01.org

To subscribe or unsubscribe via the World Wide Web, visit
        https://lists.01.org/mailman/listinfo/connman
or, via email, send a message with subject or body 'help' to
        connman-requ...@lists.01.org

You can reach the person managing the list at
        connman-ow...@lists.01.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of connman digest..."


Today's Topics:

   1. Cellular Technology with Connmanctl working only after board
      reboot  (Sonu Abraham)


----------------------------------------------------------------------

Message: 1
Date: Tue, 10 Apr 2018 07:08:52 +0000
From: Sonu Abraham <sonu.abra...@rfi.com.au>
To: "connman@lists.01.org" <connman@lists.01.org>
Subject: Cellular Technology with Connmanctl working only after board
        reboot 
Message-ID:
        
<eeda68970ac70545a004a26d194f8a69266d8...@rfi-dcu-ex01.inside.rfi.com.au>
        
Content-Type: text/plain; charset="iso-8859-1"

Hi ,

I am trying to use Connman to enable cellular connectivity in one of our 
embedded board.
When i try to run the command for enabling cellular I get the following error

connmanctl> enable cellular
Error cellular: Method "SetProperty" with signature "sv" on interface 
"net.connman.Technology" doesn't exist



I get the below output when listing technologies

connmanctl technologies
/net/connman/technology/p2p
  Name = P2P
  Type = p2p
  Powered = False
  Connected = False
  Tethering = False
/net/connman/technology/wifi
  Name = WiFi
  Type = wifi
  Powered = True
  Connected = False
  Tethering = False
/net/connman/technology/bluetooth
  Name = Bluetooth
  Type = bluetooth
  Powered = False
  Connected = False
  Tethering = False
/net/connman/technology/gadget
  Name = Gadget
  Type = gadget
  Powered = True
  Connected = False
  Tethering = False
/net/connman/technology/ethernet
  Name = Wired
  Type = ethernet
  Powered = True
  Connected = True
  Tethering = False


If I reboot the board after this and run the same command again in commanctl , 
the above command works

Can anyone suggest what could be going wrong ?

What are the methods to debug such a behavior ?

How to enable cellular technology when building  connman from source code . I 
am using yocto for building the images for the target

Thanks in advance ,
Sonu Abraham
Software Engineer

-------------- next part --------------
An HTML attachment was scrubbed...
URL: 
<http://lists.01.org/pipermail/connman/attachments/20180410/96699044/attachment-0001.html>

------------------------------

Subject: Digest Footer

_______________________________________________
connman mailing list
connman@lists.01.org
https://lists.01.org/mailman/listinfo/connman


------------------------------

End of connman Digest, Vol 30, Issue 2
**************************************

Reply via email to