https://bugs.contribs.org/show_bug.cgi?id=10514

            Bug ID: 10514
           Summary: update to backupPC 4
    Classification: Contribs
           Product: SME Contribs
           Version: 9.2
          Hardware: ---
                OS: ---
            Status: CONFIRMED
          Severity: normal
          Priority: P3
         Component: smeserver-BackupPC
          Assignee: dan...@firewall-services.com
          Reporter: te...@pialasse.com
        QA Contact: contribteam@lists.contribs.org
  Target Milestone: ---

install the BackupPC4 (SME 9.X)

installfws repo

yum --enablerepo=smecontribs,fws install smeserver-BackupPC BackupPC4updates
configuration files following the installation


Dépendance(s) installée(s) :
  BackupPC-XS.x86_64 0:0.57-1                                           
perl-Archive-Zip.noarch 0:1.30-2.el6                                
  perl-Class-Singleton.noarch 0:1.4-6.el6                               
perl-DateTime.x86_64 1:0.5300-3.el6                                 
  perl-DateTime-Format-Mail.noarch 0:0.3001-6.el6                       
perl-DateTime-Format-W3CDTF.noarch 0:0.04-8.el6                     
  perl-Net-FTP-AutoReconnect.noarch 0:0.3-3.el6                         
perl-Net-FTP-RetrHandle.noarch 0:0.2-3.el6                          
  perl-Params-Validate.x86_64 0:0.92-3.el6                              
perl-Time-modules.noarch 0:2006.0814-5.el6                          
  perl-XML-RSS.noarch 0:1.45-2.el6                                      
rsync-bpc.x86_64 0:3.0.9.11-1                                       
  smeserver-remoteuseraccess.noarch 0:1.3-2.el6.sme                     

Terminé !



then



signal-event backuppc-update


then conect to the manager ; left panel is ok, but main page will display :


Error: Unable to connect to BackupPC server

This CGI script (/BackupPC) is unable to connect to the BackupPC server on
localhost port -1.
The error was: unix connect: No such file or directory.
Perhaps the BackupPC server is not running or there is a configuration error.
Please report this to your Sys Admin.

message log shows: 
Feb  9 15:03:11 atlas esmith::event[27815]: Processing event: backuppc-update 
...
Feb  9 15:03:13 atlas esmith::event[27815]: adjusting non-supervised backuppc
(restart) 
Feb  9 15:03:13 atlas esmith::event[27815]: Shutting down BackupPC:
#033[60G[#033[0;31mÉCHOUÉ#033[0;39m]#015 
Feb  9 15:03:14 atlas esmith::event[27815]: Starting BackupPC: 2018-02-09
15:03:14 $Conf{PingPath} = '/usr/bin/ping' is not a valid executable program 
Feb  9 15:03:14 atlas esmith::event[27815]:
#033[60G[#033[0;31mÉCHOUÉ#033[0;39m]#015 
Feb  9 15:03:14 atlas esmith::event[27815]: serviceControl: Couldn't
system(/etc/rc.d/rc7.d/S98backuppc, restart):  
Feb  9 15:03:14 atlas esmith::event[27815]: adjusting supervised httpd-e-smith
(sigusr1) 
Feb  9 15:03:14 atlas esmith::event[27815]: adjusting supervised httpd-e-smith
(up) 
Feb  9 15:03:14 atlas esmith::event[27815]: adjusting supervised httpd-bkpc
(sigusr1) 
Feb  9 15:03:14 atlas esmith::event[27815]: adjusting supervised httpd-bkpc
(up) 
Feb  9 15:03:14 atlas esmith::event[27815]:
adjust-services=action|Event|backuppc-update|Action|adjust-services|Start|1518206593
394499|End|1518206594 41029|Elapsed|0.64653


editing the file /etc/BackupPC/config.pl at line 1588
$Conf{PingPath} = "/bin/ping";
to
$Conf{PingPath} = "/usr/bin/ping";

fixes this
# /etc/init.d/backuppc start
Starting BackupPC:                                         [  OK  ]

-- 
You are receiving this mail because:
You are the QA Contact for the bug.
_______________________________________________
Mail for each SME Contribs bug report
To unsubscribe, e-mail contribteam-unsubscr...@lists.contribs.org
Searchable archive at https://lists.contribs.org/mailman/public/contribteam/

Reply via email to