On 15/08/2019 16:22, Claes Redestad wrote:
This mostly looks good. In LazyCodeSourcePermissionCollection it think
"initialize" should be renamed to "ensureAdded" as that more accurately
describes what it does. Also the class description could do with a bit
of word smiting to make it clear that permissions for a CodeSource are
lazily added to the underlying permission collection.
(adding back core-libs-dev)
seems easy enough to add a writeReplace: