On Mon, 22 Feb 2021 12:04:14 GMT, Conor Cleary <ccle...@openjdk.org> wrote:

>> This is a very simple and trivial improvement about getting rid of pointless 
>> char wrapping into array
>
> src/java.base/share/classes/java/io/ObjectStreamClass.java line 833:
> 
>> 831:             String fname = in.readUTF();
>> 832:             String signature = ((tcode == 'L') || (tcode == '[')) ?
>> 833:                 in.readTypeString() : String.valueOf(tcode);
> 
> Certainly more readable and it seems that the call to valueOf is equivalent 
> to whay takes place with the original code. I can't see any difference 
> semantically or performance-wise at a glance. LGTM

Nice cleanup. I can help file a JBS issue if @c-cleary doesn't notice your 
comment.

-------------

PR: https://git.openjdk.java.net/jdk/pull/2660

Reply via email to