> This PR contains the API and implementation changes for JEP-419 [1]. A more 
> detailed description of such changes, to avoid repetitions during the review 
> process, is included as a separate comment.
> 
> [1] - https://openjdk.java.net/jeps/419

Maurizio Cimadamore has updated the pull request with a new target base due to 
a merge or a rebase. The pull request now contains 32 commits:

 - Merge branch 'master' into JEP-419
 - Revert removal of upcall MH customization
   (This change caused spurious VM crashes, so reverting to baseline)
 - Further tweak upcall safety considerations
 - Clarify safety considerations for upcalls
 - Rename MemorySegment::ofAddressNative to MemorySegment::ofAddress
   (which is consistent with other restricted factories in VaList and 
NativeSymbol)
 - Streamline javadoc for package-info
 - * Add two new CLinker static methods to compute upcall/downcall method types
   * Clarify section on CLinker downcall type
   * Add section on CLinker safety guarantees
 - Fix TestUpcall
   * reverse() has a bug, as it doesn't tweak parameter types
   * reverse() is applied to the wrong MH
 - Make ArenaAllocator impl more flexible in the face of OOME
   An ArenaAllocator should remain open for business, even if OOME is thrown in 
case other allocations can fit the arena size.
 - Simplify ArenaAllocator impl.
   The arena should respect its boundaries and never allocate more memory than 
its size specifies.
 - ... and 22 more: https://git.openjdk.java.net/jdk/compare/aea09677...8c3860f8

-------------

Changes: https://git.openjdk.java.net/jdk/pull/5907/files
 Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=5907&range=22
  Stats: 14686 lines in 193 files changed: 6956 ins; 5120 del; 2610 mod
  Patch: https://git.openjdk.java.net/jdk/pull/5907.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/5907/head:pull/5907

PR: https://git.openjdk.java.net/jdk/pull/5907

Reply via email to