On Tue, 17 May 2022 10:19:04 GMT, Jorn Vernee <jver...@openjdk.org> wrote:
>> src/java.base/share/classes/jdk/internal/foreign/abi/CallingSequence.java >> line 109: >> >>> 107: * @return the caller method type. >>> 108: */ >>> 109: public MethodType callerMethodType() { >> >> Would it make sense to either rename these, or to point to the fact that >> these are equivalent to Linker::downcallType/upcallType ? > > I don't think renaming them to down/upcallType makes sense, since both > down/up calls use both the caller and callee method type. There can also be > things that make these not equivalent to downcallType/upcallType, such as the > SysV need to pass the number of floating point arguments for variadic calls > as well: > https://github.com/openjdk/jdk/blob/master/src/java.base/share/classes/jdk/internal/foreign/abi/x64/sysv/CallArranger.java#L109-L111 I've left this as is for now. ------------- PR: https://git.openjdk.java.net/jdk/pull/8685