Hi!

Adding the dependency the code compiles ok, but nothing happens.


I've been able to get a TPM2.0 with SPI, a supported SLB9670. I've added


    select TPM2
    select MAINBOARD_HAS_TPM2
    select SPI_TPM

to the Kconfig of my mainboard/amd/bettong. It compiles ok but nothing happens.

I've trace the initialization to tpm2:


tlcl_lib_init -> tis_init -> tpm2_init


but 'tlcl_lib_init' it seems to depend on vboot and with this AMD board no 
vboot is implemented.


I've tried to call tis_init from the board romstage.c :


void agesa_postcar(struct sysinfo *cb)
{
    post_code(0x41);
    AGESAWRAPPER(amdinitenv);

    tis_init();

    if (acpi_is_wakeup_s4()) {
        outb(0xEE, PM_INDEX);
        outb(0x8, PM_DATA);
    }
}


but a linking error is show:


    LINK       cbfs/fallback/romstage.debug
build/romstage/drivers/spi/spi-generic.o: In function `spi_setup_slave':
/mnt/develop/bettong/coreboot/master/coreboot/src/drivers/spi/spi-generic.c:129:
 undefined reference to `spi_ctrlr_bus_map'
/mnt/develop/bettong/coreboot/master/coreboot/src/drivers/spi/spi-generic.c:131:
 undefined reference to `spi_ctrlr_bus_map_count'
/mnt/develop/bettong/coreboot/master/coreboot/src/drivers/spi/spi-generic.c:134:
 undefined reference to `spi_ctrlr_bus_map'
build/romstage/drivers/spi/tpm/tpm.o: In function `stopwatch_tick':
/mnt/develop/bettong/coreboot/master/coreboot/src/include/timer.h:155: 
undefined reference to `timer_monotonic_get'
build/romstage/drivers/spi/tpm/tpm.o: In function `stopwatch_init':
/mnt/develop/bettong/coreboot/master/coreboot/src/include/timer.h:131: 
undefined reference to `timer_monotonic_get'
/mnt/develop/bettong/coreboot/master/coreboot/src/include/timer.h:131: 
undefined reference to `timer_monotonic_get'
/mnt/develop/bettong/coreboot/master/coreboot/src/include/timer.h:131: 
undefined reference to `timer_monotonic_get'
make: *** [build/cbfs/fallback/romstage.debug] Error 1

Any hint?


Thanks!

Jorge

________________________________
De: Zaolin <zao...@das-labor.org>
Enviado: jueves, 17 de mayo de 2018 0:08:24
Para: Jorge Fernandez Monteagudo; coreboot@coreboot.org
Asunto: Re: [coreboot] SPI TPM question


Hey,


The SPI tpm driver was written for tpm 2.0 only.
You can try to add TPM to "depends on" as well and see what happens.

Let us know if it works. :)


Best Regards, Philipp

On 15.05.2018 19:53, Jorge Fernandez Monteagudo wrote:

Hi all!


This is my first message to the list. I would like to know if the TPM1.2 is 
supported through SPI?

Enabling SPI_TPM and TPM in my board configuration throw an error. From 
src/drivers/spi/tpm/Kconfig

I can see the dependency:


config SPI_TPM
    bool "SPI TPM"
    depends on TPM2

Any options to get TPM1.2 SPI support?


Thanks!

Jorge



-- 
coreboot mailing list: coreboot@coreboot.org
https://mail.coreboot.org/mailman/listinfo/coreboot

Reply via email to