Hi,

Thanks a lot. I checked if there are /usr/include/attr/libattr.h and  
/usr/include/attr/error_context.h in Ubuntu 18. I could not find them. Then I 
install sudo apt install libattr1-dev. Then can pass  sudo make check  
TESTS=./tests/cp/capability.sh SUBDIRS=. VERBOSE=yes .

When I search how to install xattr, I only find the solution sudo apt install 
xattr.

Thanks A LOT!!!!!!!

________________________________
From: Kaz Kylheku (Coreutils) <962-396-1...@kylheku.com>
Sent: Thursday, October 10, 2019 10:25:24 PM
To: Wei MA
Cc: coreutils@gnu.org
Subject: Re: Compile Coreutils without xattr but i installed

On 2019-10-10 11:56, Wei MA wrote:
> I compile the source code. And when i ran   tests/cp/capabiliy.sh, cp
> preserves attr failed without xattr support . Then i installed xattr.
> I deleted coreutils and downloaded it again. The problem still exists.

A configure problem likely won't be due to a bad copy of coreutils;
you have to debug where that is going wrong: why it isn't detecting
the xattr.

It looks like the Coreutils configure script looks for two headers:
<attr/error_context.h> and <attr/libattr.h>.

It also looks for a function attr_copy_file in libattr.

See: http://git.savannah.gnu.org/cgit/coreutils.git/tree/m4/xattr.m4

> I use Ubuntu 18. When i ran cp of Ubuntu, the same commands has no
> problem.

A possibility may be to find the Ubuntu 18 build recipe for coreutils
and find out what it's doing differently from you. Does it pass
something to the configure script or force any Autoconf variables
(ac_cv_whatevers). Does it apply any patches, etc.


-----------------------------------------------------------------------------------

This e-mail can not be trusted due to SPF/DKIM validation failed.

-----------------------------------------------------------------------------------

Reply via email to