On Tue, Jun 12, 2018 at 11:46 PM Carsten Reckord <reck...@yatta.de> wrote:

> Hey everybody,
>
>
>
> while diagnosing a problem with reporting install errors in the
> Marketplace Client (https://bugs.eclipse.org/bugs/show_bug.cgi?id=535821),
> I noticed that since RC3 we have two versions of HttpClient 4.5.2 in the
> Simrel repository.
>
>
>
> I’m not sure yet if this is the cause of my bug in MPC, but in the past,
> these kind of version mixups have always been problematic.
>
>
>
> I’ve dug around a bit (for details, see
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=535821), and the two
> versions are contributed by the Platform
> (org.apache.httpcomponents.httpclient_4.5.2.v20170210-0925) and by JGit
> (org.apache.httpcomponents.httpclient_4.5.2.v20180410-1551 – this one is
> new in RC3). The newer HttpClient version was introduced in Orbit
> I20180417184143 to make it safely co-exist with commons.logging 1.2 and
> commons.codec 1.10, neither of which are currently found in the Simrel
> repository.
>
>
>
> While the version contributed by JGit is the current one from the Orbit
> Photon repository, I think at this point the easiest and safest thing to do
> would be for JGit to go back to the old version to get a consistent state
> of the Simrel repo again. The alternative would be to update ECF with the
> new version, respin the platform, and get the Mylyn SDK to use the new
> version as well.
>
>
>
> What do you think?
>
>
>
> Kind regards,
>
> Carsten Reckord
>

org.eclipse.jgit.http.apache is an optional bundle which is not used by
EGit.
It's used in JGit by org.eclipse.jgit.lfs.server (supports implementation
of a git lfs server)
and org.eclipse.jgit.pgm (jgit command line client).

-Matthias
_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@eclipse.org
To change your delivery options, retrieve your password, or unsubscribe from 
this list, visit
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev

Reply via email to