On Thu, Aug 25, 2011 at 06:52:51PM +0200, Yang Tse wrote:
> #define CURLMAIL_AUTH_LOGIN       (1<<0)
> #define CURLMAIL_AUTH_PLAIN       (1<<1)
> #define CURLMAIL_AUTH_CRAM_MD5    (1<<2)
> #define CURLMAIL_AUTH_DIGEST_MD5  (1<<3)
> #define CURLMAIL_AUTH_GSSAPI      (1<<4)
> #define CURLMAIL_AUTH_EXTERNAL    (1<<5)
> #define CURLMAIL_AUTH_NTLM        (1<<6)

As I brought up in March when this first came up, since SMTP uses SASL
for authentication, I suggest renaming these to something like
CURL_SASL_AUTH_x so that they can be used for other SASL-using protocols
in the future.

>>> Dan
-------------------------------------------------------------------
List admin: http://cool.haxx.se/list/listinfo/curl-library
Etiquette:  http://curl.haxx.se/mail/etiquette.html

Reply via email to