On Fri, 16 Sep 2016, Martin Storsjö wrote:

-Werror=partial-availability is probably safe to add by default (if the compiler supports it), since it matches how configure checks are used - if a function is available and can be linked, we're free to use it.

But then we also need to make sure the user sets a sensible -mmacosx-version-min or -miphoneos-version-min, which hasn't been quite necessary so far. Or do OSX users generally set those whenever building things?

I would expect that people building curl mostly just use what configure generates for them.

Should configure warn if they aren't set - or set a sensible default low version if it isn't? Given the number of current and legacy systems that one can build it for, picking a sensible default is a bit tricky.

I really can't tell how to do this as I know next to nothing about how macOS/iOS versions differ and change between releases.

If nobody else speaks up, make an educated guess that seems to work for you and then we move forward and adjust accordingly if people find problems with the current set?

I would really appreciate some help on fixing this configure issue. I think it would be a pity to keep releasing curl without having this issue sorted out. Even if the blame for this is totally not ours.


 / daniel.haxx.se
List admin: https://cool.haxx.se/list/listinfo/curl-library
Etiquette:  https://curl.haxx.se/mail/etiquette.html

Reply via email to