Meanwhile, I found that at least /usr/bin/gcc and /sbin/reboot are
empty files. I upgraded to 9.99.37 via "sysupgrade auto $URL".

On Tue, Jan 14, 2020 at 2:18 PM Chavdar Ivanov <ci4...@gmail.com> wrote:
>
> On Tue, 14 Jan 2020 at 11:57, Rares Aioanei <bsdlis...@gmail.com> wrote:
> >
> > Unsure if related or not, but I updated pkgsrc, then ran
> > "pkg_rolling-replace -u" . Suddenly gcc3 became a dependency to
> > py-setuptools, and gcc3 needs binutils, which fails at the configure
> > step with "C compiler cannot create executables". I switched to
> > another terminal, wrote a short hello world in C and indeed, gcc
> > (/usr/bin/gcc) does nothing, not even an error. Even "gcc -v" does
> > nothing, and afterwards, "echo $?" returns 0. FWIW, I rebooted, to no
> > avail. Also running 9.99.37, amd64, VBox guest, Linux host.
>
> That confirms my suspicions as well. At present I am updating an
> XCP-NG guest, which was running 9.99.26; I updated first pkgsrc and
> confirmed everything works as expected. Next I am bringing it up to
> 9.99.36, testing and finally will do the same with 9.99.37.
>
> >
> > On Tue, Jan 14, 2020 at 1:06 PM Chavdar Ivanov <ci4...@gmail.com> wrote:
> > >
> > > On Tue, 14 Jan 2020 at 10:52, Chavdar Ivanov <ci4...@gmail.com> wrote:
> > > >
> > > > Hi,
> > > >
> > > > I bumped up my development machine to 9.99.37; after that I usually
> > > > rebuild pkgtools/osabi and all that depend on it; this usually does
> > > > not cause problems (with the exception of lsof, which I had installed
> > > > some times ago and which does not build any more at all, as it is
> > > > using apparently internal to the kernel interfaces).
> > > >
> > > > This time it failed to build net/net-snmp, as it for some reason
> > > > decided that it has a build dependency of devel/binutils from
> > > > lang/gcc3 (which I do not have built and installed so far).;binutils
> > > > fails to build at the extract stage - as it claims built-in dependency
> > > > on itself:
> > > > root➜pkgsrc/devel/binutils» make clean
> > > >                                                          [10[6/1788]
> > > > ===> Cleaning for binutils-2.26.1nb1
> > > > root➜pkgsrc/devel/binutils» make extract
> > > >                                                          [10:18:31]
> > > > => Bootstrap dependency digest>=20010302: found digest-20190127
> > > > => Checksum SHA1 OK for binutils-2.26.1.tar.bz2
> > > > => Checksum RMD160 OK for binutils-2.26.1.tar.bz2
> > > > => Checksum SHA512 OK for binutils-2.26.1.tar.bz2
> > > > ===> Installing dependencies for binutils-2.26.1nb1
> > > > => Tool dependency libtool-base>=2.4.2nb9: found libtool-base-2.4.6nb2
> > > > => Tool dependency bison>=1.0: found bison-3.4.2
> > > > => Tool dependency gmake>=3.81: found gmake-4.2.1nb1
> > > > => Build dependency cwrappers>=20150314: found cwrappers-20180325
> > > > => Full dependency gcc3-c>=3.3.5nb1: NOT found
> > > > => Verifying reinstall for ../../lang/gcc3-c
> > > > => Bootstrap dependency digest>=20010302: found digest-20190127
> > > > => Checksum SHA1 OK for gcc-3.3.6.tar.bz2
> > > > => Checksum RMD160 OK for gcc-3.3.6.tar.bz2
> > > > => Checksum SHA512 OK for gcc-3.3.6.tar.bz2
> > > > ===> Installing dependencies for gcc3-c-3.3.6nb1
> > > > => Tool dependency ccache-[0-9]*: found ccache-3.7.6
> > > > => Tool dependency gmake>=3.81: found gmake-4.2.1nb1
> > > > => Build dependency cwrappers>=20150314: found cwrappers-20180325
> > > > => Full dependency binutils>=2.13.2.1: NOT found
> > > > => Verifying reinstall for ../../devel/binutils
> > > > ERROR: This package has set PKG_FAIL_REASON:
> > > > ERROR: Circular dependency detected
> > > > *** Error code 1
> > > >
> > > > Stop.
> > > > make[2]: stopped in /usr/pkgsrc/devel/binutils
> > > > *** Error code 1
> > > >
> > > > I ran 'make -dA'; at one stage it sets _NEED_GCC3.
> > > >
> > > > Anyway; this hasn't happen before; the pkgsrc tree was updated on the
> > > > 5th of January and pkg_rolling-replace was carried out (with a number
> > > > of failures, but overall OK). The last successful net-snmp build was
> > > > on the 11th of January under 9.99.36:
> > > >
> > > >  # ls -l /usr/pkgsrc/packages/All/net-snmp-5.7.3nb12.tgz
> > > > -rw-r--r-- 1 root wheel 4065659 Jan 11 23:19
> > > > /usr/pkgsrc/packages/All/net-snmp-5.7.3nb12.tgz
> > > >
> > >
> > > I was a bit too quick to hit 'return' on this mail. I can't build
> > > *anything* now under 9.99.37; to be sure, I updated pkgsrc and hid the
> > > present /etc/mk.conf.
> > >
> > > Any build using gcc tries to use gcc3 and then fails with the circular
> > > dependency of devel/binutils.
> > >
> > > > Chavdar
> > > >
> > > >
> > > > --
> > > > ----
> > >
> > >
> > >
> > > --
> > > ----
>
>
>
> --
> ----

Reply via email to