Author: paultcochrane
Date: Sat Mar 17 07:33:27 2007
New Revision: 17530

Modified:
   trunk/tools/dev/mk_manifest_and_skip.pl

Log:
[tools]
 - made directory checking code more readable


Modified: trunk/tools/dev/mk_manifest_and_skip.pl
==============================================================================
--- trunk/tools/dev/mk_manifest_and_skip.pl     (original)
+++ trunk/tools/dev/mk_manifest_and_skip.pl     Sat Mar 17 07:33:27 2007
@@ -144,13 +144,13 @@
     return if $File::Find::name =~ m{runtime.parrot.library.PAST};
 
     $File::Find::name =~ s[^\./][];
-    # TODO: change to if (-d $_) { push @dirs, $File::Find::name; }
-    -d and push @dirs, $File::Find::name;
+    if ( -d $_ ) {
+        push @dirs, $File::Find::name;
+    }
 
     #my $result = system(qq($cmd propget svn:mime-type $_));
-    # TODO: -f $svnbase should be -f $_
     my $svnbase = ".svn/text-base/$_.svn-base";
-    if (-f $_ and -e $svnbase) {
+    if ( -f $_ and -e $svnbase ) {
         MANIFEST();
     }
 

Reply via email to