Author: paultcochrane
Date: Sat Mar 17 07:12:14 2007
New Revision: 17528

Modified:
   trunk/tools/dev/mk_manifest_and_skip.pl

Log:
[tools]
 - converted use of multiple 'and' usage to a hopefully more readable if()
   statement


Modified: trunk/tools/dev/mk_manifest_and_skip.pl
==============================================================================
--- trunk/tools/dev/mk_manifest_and_skip.pl     (original)
+++ trunk/tools/dev/mk_manifest_and_skip.pl     Sat Mar 17 07:12:14 2007
@@ -145,7 +145,11 @@
 
     $File::Find::name =~ s[^\./][];
     -d and push @dirs, $File::Find::name;
-    -f and -e ".svn/text-base/$_.svn-base" and MANIFEST();
+
+    my $svnbase = ".svn/text-base/$_.svn-base";
+    if (-f $svnbase and -e $svnbase) {
+        MANIFEST();
+    }
 
     return;    # ignored
 }

Reply via email to