Author: bernhard
Date: Fri May 18 11:12:07 2007
New Revision: 18583
Modified:
trunk/compilers/imcc/main.c
Log:
Rename pre_process to pre_process_only, as
calling 'do_pre_process' is not the usual thing.
Modified: trunk/compilers/imcc/main.c
==============================================================================
--- trunk/compilers/imcc/main.c (original)
+++ trunk/compilers/imcc/main.c Fri May 18 11:12:07 2007
@@ -21,7 +21,7 @@
#include "pbc.h"
#include "parser.h"
-static int load_pbc, run_pbc, write_pbc, pre_process, pasm_file;
+static int load_pbc, run_pbc, write_pbc, pre_process_only, pasm_file;
static void
usage(FILE* fp)
@@ -291,7 +291,7 @@
yydebug = 1;
break;
case 'E':
- pre_process = 1;
+ pre_process_only = 1;
break;
case 'o':
run_pbc = 0;
@@ -629,7 +629,7 @@
}
}
}
- if (pre_process) {
+ if (pre_process_only) {
do_pre_process(interp);
Parrot_destroy(interp);
yylex_destroy(yyscanner);