On Jul 2 19:43, Christopher Faylor wrote: > On Sat, Jul 02, 2011 at 06:42:04AM +0100, Andy Koppe wrote: > >Hmm, the two-character ut_id would actually be a problem with Unix98 > >ptys, because according to Linux's 'man utmp' it's supposed to be 'p' > >followed by the pts number there. This would only allow for 10 ptys. > > > >How about going with the BSD scheme as previously used on Linux? > >Should be much less work than Unix98 ptys as well. > > > >consoles: ttyN > >pty masters: /dev/pty[p-za-e][0-9a-f] > >pty slaves: /dev/tty[p-za-e][0-9a-f] > > > >The [p-za-e][0-9a-f] encoding allows for up to 256 pseudo terminal > >pairs and fits into ut_id. > > If it boils down to making the tty number look more like linux > (/dev/pts/10) or just puting a "10" in ut_id, I'd opt for just putting > the "10" there. The "p" really wouldn't make any sense for Cygwin since > we no longer have ttys.
But how do you differ between console 10 and tty 10? The BSD/old-Linux naming scheme seems a good way to accomplish that. Corinna -- Corinna Vinschen Please, send mails regarding Cygwin to Cygwin Project Co-Leader cygwin AT cygwin DOT com Red Hat
